After creating an epic, I can't see it in the Epic panel

I selected a specific board. It doesn't have any active sprints yet but it does have a backlog.

I created a new epic while inside this particular board. After creating it, I got a message that the epic has been created but is not yet visible. I can't see it in the epic panel. If I look at any issues that belong to this board and tr to edit the epic link field this epic doesn't show up.

There are other related posts but none of them seemed to solve my problem. Any help is appreciated.

 

3 answers

In Jira, Epics doesn't show up in boards (Scrum/Kanban). Epics can be used to differentiate the stories by using swim lanes. Epics can be accessed from Issue navigator with JQL "project = <project-name> AND issuetype = Epic"  Anyways Epics are used to track large chunks of project progress. An epic can only be closed if all the stories in it  are closed. 

I am facing an similar but opposite issue. A few notes:

  • There is just one project and one scrum board and the filter is "Project=NAME ORDER BY Rank ASC" shared with the entire project
  • The epics that are not visible on this board have stories assigned to it and those stories show up on the board (I don't know how)
  • These invisible epics are not resolved and are still in the 'Not Done' or 'In progress' state which are mapped statuses for this board in question
  • All these epics are visible in the filter results but not on the board created from the same filter.
  • All newIy created epics are being added here. The existing epics that were created by others are not seen (No quick filter 'reported by me' selected)

Can someone please help out with this?

Thanks in advance.

I'm seeing this same problem.  Were you able to figure out why, or a resolution?  TIA

Paolo, have you checked the filter backing the board? Does it contain a single project or multiple projects? Does it perhaps exclude these epics?

Have you created the epic from inside the board or via the main Create button?

Can you find the epics in the Issue Navigator as veera suggested?

Isn't it possible that the epics were created in a different project?

Hi TIbor, I have created the epic from the project's board. Other epics that are used in that project show fine when you click on the EPICS panel but the newly created one doesn't. I used the Create Epic link from the screen shot below inside an existing board (13.0 Initiative).

Thanks!

image2016-4-6 10:20:46.png

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Feb 15, 2018 in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

1,123 views 6 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot