Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,706
Community Members
 
Community Events
176
Community Groups

Why isn't this script working to restrict subtasks from being created under Epics?

I am trying to restrict sub-tasks from being created underneath epics. I have seen that the following scripts have worked for folks, but I can't get them to work for me. Please let me know if you see what I am doing wrong! Attached is a photo of one of the scripts in the validator section of the create transition. Help!

!["Epic"].contains(issue.parentObject?.issueType.name)
["Task", "Bug"].contains(issue.parentObject?.issueType.name)

Screen Shot 2021-08-31 at 9.54.38 AM.png

2 answers

Hi Julia, I tried using the same script that you used, and it worked in my Jira instance. Like what Martin mentioned above, the execution history shows that it had not run yet, were the changes saved and applied successfully?

If the validator ran and failed, it would've shown up in the history and tell us why it failed.

Hi @Julia ,  I can see that validator has not ran yet. Did you publish your workflow's draft?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events