Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to hit the JIRA cloud instance APIs

HI, 

We are developing the plug-in connector for Atlassian JIRA and one of our client tools. We are doing some analysis about the JIRA cloud instance.

For this purpose, we have created a free trial account for cloud instance. But we are not able to access APIs.

 It would be great if we get to know how to activate the >> Accept remote API calls option with this trial account to solve the issue.

 

Thanks in advance,

Pallavi

2 answers

Now, REST API is enabled by default. We used to enable it as in here: 

 https://confluence.atlassian.com/display/JIRACLOUD/Configuring+JIRA+Options#ConfiguringJIRAOptions-Options.

But with JIRA 7, the option is set to ON by default so there is no need to make any change. That's mentioned at JRA-44822

Further guideline: https://docs.atlassian.com/jira/REST/ondemand/

Sample test with the right details can be done through: https://<domain>.atlassian.net/rest/api/2/search?jql&fields=key

Thanks Diallo for the Updates We are using Cloud Jira instance: JIRA v7.0.0-OD-08-001, but not getting "Accept remote API calls" option in JIRA Administrator >> System >> Edit Settings>> Options field All other options like Logout confirmation, Use gzip compression, External user management etc are available. Is this option ("Accept remote API calls") available with free trial (7 days) cloud instance? Any pointers will be halpful

It seems the option is removed. But once again the REST API is by default ON/enabled.

We have procure the licence of JIRA cloud instance,
Site Address: cloudjira.atlassian.net

But through Rest Client, i am not able to access the API's. Below are the details of request

URL: https://<cloud instance URL>/rest/api/auth/2/version/10006
authorization: base64 encoded form of <username:password>
contect-type: application/json

Response: Getting 

401 Unauthorized

Any pointers will be helpful. We need to start our work with cloud instance

Hi Pallavi,

I am also facing same issue , After providing the authorization: base64 encoded form of <username:password> , I am still getting 

Response: Getting 401 Unauthorized

Can you tell me how it was rectified

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

319 views 9 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you