Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,622
Community Members
 
Community Events
168
Community Groups

Unable to connect to the zfj-importer.

zfj-importer -utility-0.38.jar

Unable to connect to the Zephyr Testcase Importer.

Using cloud URL and an administrators Username and password.

When hit connect - gives a pop up message stating:

Error fetching projects

Unexpected response code: 401

However was connecting fine previously without any issues. Also tried to regenerate the API keys.

 

 

1 answer

1 accepted

0 votes
Answer accepted
Dario B Atlassian Team Aug 23, 2019

Hi @Josin Joseph ,

If you are trying to connect to Jira Cloud then instead of using username and password you should be using email address and API Token to authenticate.

This is because basic authentication with username and password has been removed in Cloud as previously announced. 

For details and instructions please see:

 

Please let me know if this helps.

 

Cheers,
Dario

Even i face similar issue. I created API tokens newly when i tried to connect Zephyr with JIRA using the emailaddress, API token & API key - I'm getting peer not authenticated issue.

I am using the latest JAR file (40).

Can you provide any other workaround.

Hi @Dinesh ,

If you get  the "peer not authenticated" error message, you may want to re-generate API token and API key for your account and re-try.

If this still does not work you may want to:

 

Finally, please notice that this question is marked as resolved. If the solution in here does not apply to you there are good chances you are having a different issue. Therefore, it would be best to create a new question (thread) for it.

 

 

Ciao,
Dario

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events