Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Test case upload through utility importer but when i try to find it on Jira there is no test case imported? Kindly help me

13 answers

I'm currently facing this issue. I've contacted technical support and followed the instructions, but still no luck and same success message with no test cases actually appearing in Jira. I have full admin rights so there's no reason I could not see them in the project, unless they're just not there.  It's also completing the "import" within about a second, which leads me to believe it didn't actually do anything. Any help is appreciated! Thank you

hi there,

Did you check your profile and your 'Activity stream' where newly created test case would be listed. As I have shown above, i was able to locate my test cases from my recent activity history .

Hope that helps.


I had imported Successfully But only Name is displaying. Rest of the mapped fields are not displaying in JIra

Hi Nabiha,

Please find below screen where there was a message of issue being created and I went to my Jira profile and checked at my recent activity to locate the test case created by importer.




Locating tets case.png

Any luck with this? I am still facing the same issue.

Hi All, 


I am facing similar issue. Able to import in utility but can not view the issue in JIRa.


Any solutions?

Hi everyone,

I am getting the same issue. i tried to import test cases and the utility says its done however nothing got imported. Were you able to resolve the issue?

i am following this documentation :


Best Regards


I am also facing the same issue as Karan and Nabiha are facing. Getting a success message from the importer utility but not able to find my test cases in Jira. Is there any fix for this? I have a huge number of test cases that needs to be Jira. Is there a possible work around to be able to find my test cases in Jira?

It's the same answer - Karan and Nabiha stopped posting here because they were asked to give the results of a search, and then found their tests when they ran the search.

Its not like I have stopped posting here. I left it and trying alternate manual approaches for completing my task because I did not find any relevant answer for this in past chats/blogs as well. I have shared my personal details for resolving the issue what else we can do.

People in past already had unnecessary long debate regarding search result but no way out. By the way no one asked me for the search result. In my case utility was showing as successfully uploaded and support person is asking that you need administrator rights? I already tried with administrator privilages.

This is extremely unstable api. If anyone still want to ask anything he can contact me from their official channel on my details.

Nic Brough is not helping.

How hard is it to understand that the search query your asking is returning EMPTY.

no results. nada. empty


privilages. Yes this is my project. Import status from zephyr returned this "CST 2018 Test.xlsx imported successfully..! "

After checking in JIRA, NONE, NADA, EMPTY

fyi all query. ALL query

That's the problem. NONE

Can anyone else other than Nic Brough answer?

Like Chris Allan likes this

I have read all the comments properly. nabiha has valid concern.

I am also facing the same issue, false message is coming while importing with "By Testcase name Change" option. Attached is the screenshot for the same. looks like this is static hardcoded message. I have taken the latest version of importer i.e. 38.

By selecting other options in Descriminator. some irrelevant messages are coming. 

I have read so many blogs of this article on number of sites. Tried much number of things. Even I did not find anyone whose problem has been solved. Looks like this is extremely unstable and immature utility.

If anyone still confident about it, requesting him/her to please help me in solving this issue. My contact details are:-, Ph. No - +91-7838128000

zephyr importer screenshot.png 

So the importer has imported nothing, or you can't see the imported issues, due to permissions (or issue security) in the project.  Please start by working out which one of those it is.

HI am still stuck . kindly assist me. Thanks

I execute the same steps but issue still exists. Kindly suggest me.

How do you know it's importing them as "tests"?  Could it have done them as a different issue type?

Try running a filter for "all issues order by created desc" immediately after the import to see what has come in.

from zfj-importer-utility i have select the issue type as TEST and select sepfice project as well. I search it through issue type, project and also all issues type but am, stil stuck .please help me.

What happens when you run the filter I suggested after the import?

Please, use the standard JIRA issue navigator to do this, don't mess around with other applications.

Dear NIC Brough,

I followed the same steps which are mention in attached file.

But when i try to find test case on zephy I didn’t find any test case there. What should i do? Kindly suggest me. I tried to search imported test cases with generic search i.e. issue type , project wise etc.


Note: I am the user of cloud based JIRA. waiting for your prompt response. Thanks


Could you try running a filter for "all issues order by created desc" immediately after the import to see what has come in.

Yes i tried it. But when i try to find test case on zephy I didn’t find any test case there. Kindly suggest me.

"I tried it" tells us precisely nothing.  Did you use the exact filter I suggested?  What does it tell you?

Yes, as we discussed earlier I used the following filter:

Type = Test


Also I had search with open filter i.e. 

Type = All

But still JIRA not found my required testcases.

If sill you are not getting my point please give me your skype id, may be we can solve this issue easily with voice conversation.

Waiting for your prompt response.


So the importer has imported nothing, or you can't see the imported issues, due to permissions (or issue security) in the project.

  You need to look into that before doing anything else.

yes i have permission in this project for uploading . i have check it , But still JIRA not found my required test cases.

Ah, sorry, I misread that last one.

Could you please run the filter I suggested, as I wrote it.

I had run all filters which u were suggested in your all comments.

Ok, but you have not given us the results.

I first recommendation would be to start with a wide search.

Go to the TESTS menu option


Make your search query:  ISSUETYPE=TEST


That should return every test you have access to.  When you have that list, go to the CREATED column (might have to add it to your view) and sort by it.  Then look for the dates you imported tests.

See if that helps you.



Screen Shot 2016-04-12 at 4.31.24 PM.png

Hi Brian,

I got the same error as Nebiha. The process was successful and I couldn't find the test cases even by following your search suggestion. 

What would be the problem ?

Hi Brian,

I am using Zephyr. Through zfj-importer-utility am importing test cases in .xlsx format. Test case import successfully and success folder has been created. Success message display. But i when i try to find test case on zephyr i am facing issue. I didn’t find any test case there. What should i do? Kindly suggest me. Thanks

You are going to need to provide additional information so people will be able to assist you with your issue.

JIRA doesn't natively have a test case management tool.  Did you install one?  If so which one?

With your import, did it say it succeeded?  What import tool did you use?

Do you have access to the project where the test cases went in JIRA?


Suggest an answer

Log in or Sign up to answer

Atlassian Community Events