Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira http -> https via Apache ??

I have a Windows box running Apache 2.4 http + https

and also Jira running http (port 8080) on the same box.

My understanding is that I should be able to set up something like this:

Jira <-> Apache http <-> Apache https <-> Internet

To that end I have the following in my port 443 <VirtualHost> section:

###########################################################
# START Jira Proxy Configuration: #########################
###########################################################
# This does not seem to break anything, but it also does
# not connect to the Jira server.
# https://missionctrl.info/jira -> gives a 404 error
###########################################################
<Proxy *>
Order deny,allow
Allow from all
</Proxy>

SSLProxyEngine On
ProxyRequests Off
ProxyPreserveHost On
ProxyPass "/jira/" "http://missionctrl.info:8080/"
ProxyPassReverse "/jira/" "http://missionctrl.info:8080/"

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
###########################################################
# END Jira Proxy Configuration ############################
###########################################################

</VirtualHost>

 

All the appropriate modules are active. But I'm getting a 404 error when I try to go to http://missionctrl.info/jira

Can anyone help me with this?

Here's my software version:

Atlassian Jira Project Management Software (v7.13.1#713001-sha1:5e06076)

1 answer

0 votes
Alexis Robert Community Leader May 07, 2020

Hi @Vincent Bressler , 

 

I'm more familiar with Apache on Linux, but it should not be that different on Windows.

First thing : I don't think you need to go through Apache in HTTP. The usual architecture is : 

Jira (listens on 8080) <-> Apache (listens on 443) <-> Internet.

I usually point to this guide by Atlassian to configure Apache : https://confluence.atlassian.com/adminjiraserver/integrating-jira-with-apache-using-ssl-938847754.html#IntegratingJirawithApacheusingSSL-Step2:ConfigureApacheHTTPServer

 

As your URL is formed like "https://mycompany.com/jira" you should also make sure that your Tomcat connector has the Context Path configured : https://confluence.atlassian.com/kb/proxying-atlassian-server-applications-with-apache-http-server-mod_proxy_http-806032611.html#ProxyingAtlassianserverapplicationswithApacheHTTPServer(mod_proxy_http)-2.Setthecontextpath

 

Let me know if this helps, 

 

--Alexis

Thanks for the help Alexis,

 

I now have this:

#</IfModule rewrite_module> - HAD to comment this out or Apache fails to start
###########################################################
# START Jira Proxy Configuration ############################
###########################################################
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
###########################################################
# END Jira Proxy Configuration ############################
###########################################################
#</IfModule>

 

............................................

 

# =================================================
# SSL/TLS settings
# =================================================
<IfModule ssl_module>

NameVirtualHost *:443

<VirtualHost *:443>

...............

###########################################################
# START Jira Proxy Configuration: #########################
###########################################################
# This does not seem to break anything, but it also does
# not connect to the Jira server.
# https://missionctrl.info/jira/ sort of works
# ... some weird errors seen in Jira
###########################################################
<Proxy *>
Order deny,allow
Allow from all
</Proxy>

SSLProxyEngine On
ProxyRequests Off
ProxyPreserveHost On
ProxyPass "/jira/" "http://missionctrl.info:8080/jira/"
ProxyPassReverse "/jira/" "http://missionctrl.info:8080/jira/"
###########################################################
# END Jira Proxy Configuration ############################
###########################################################

</VirtualHost>

 

http://missionctrl.info:8080/jira/ - does work

https://missionctrl.info/jira/ - sort of works but generates some errors - not really usable

Hi Alexis,

It's working, except I'm still getting some items which appear like this in the browser when I'm using Jira:

http://www.missionctrl.info/jira/secure/projectavatar?pid=10000&avatarId=10501

should be https://

These show up as broken links, and prevent me from doing much of anything.

Thanks for your help,

Vince

 

Some elements missing when https:

 

Untitled.png

The blank fields in Jira are from items which have URLs which look like this:

http://www.missionctrl.info/jira/secure/projectavatar?pid=10000&avatarId=10501

I tried to fix this in Apache by redirecting as follows:


<VirtualHost *:80>
ProxyRequests Off
ProxyPreserveHost On
ProxyPass "http://www.missionctrl.info/jira/" "http://missionctrl.info:8080/jira/"
ProxyPassReverse "http://www.missionctrl.info/jira/" "http://missionctrl.info:8080/jira/"
</VirtualHost>

But this does not fix the problem.

 

And neither does this:

<VirtualHost *:80>
ProxyRequests Off
ProxyPreserveHost On
ProxyPass "/jira/" "http://missionctrl.info:8080/jira/"
ProxyPassReverse "/jira/" "http://missionctrl.info:8080/jira/"
</VirtualHost>

Base URL is as shown. I restarted the Jira service.

Sidebar elements still not showing up. That would be okay, but I also can't add a comment to an issue.

Interestingly... when I start with a URL like this:

http://www.missionctrl.info:8080/jira/

Everything continues to work fine.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Marketplace Apps & Integrations

☕️ Monday coffee with Jexo: Weekly Atlassian news roundup | 21st June 2021

Hi community 👋, as every Monday we're bringing you a quick update on what happened in the Atlassian ecosystem last week. There were a few interesting events like for example the announcement of th...

28 views 0 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you