Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Issues with No Resolution Not Showing Up with the Unresolved Filter

When I click on the "My Open Issues" filter, it brings up the Resolution filter as "Unresolved". However, none of the new issues I've created (all which have a blank resolution value) show up when I select "Unresolved". If I delete the Resolution value filter, all my issues show up. How can I get these blank resolution issues to correctly show up as "Unresolved"?

 

Screen Shot 2019-07-22 at 2.36.17 PM.png

4 answers

2 votes
Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Jul 24, 2019

This is a long-shot, but could you log in as an admin, go to Admin -> Issues -> Resolutions and look at the list that is set up?

Is "Unresolved" listed there?

Randy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 24, 2019 • edited

Worth checking.  I didn't suggest that because his screenshot of one example shows the Unresolved in italics which wouldn't be the case if there was a resolution called Unresolved.  

Also resolved should be set with a date if that were the case also.

Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Jul 24, 2019

You'll still see that on "proper" unresolved issues even if there is one.  I just want to completely rule it out!

Like Randy likes this

No. No "Unresolved" resolution has been added to the resolution list.

Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Jul 24, 2019

Excellent, thank you.

Well, actually, not excellent in terms of working out what is wrong.  Excellent in that you've completely ruled out the usual problem, so we can focus on the less frequent ones, but not good because it does not solve the problem.

Could you pick on one of the affected issues ( Prod-5075 would be ideal, as we've seen its current state) and compare the issue view with a search view that includes it?  Then, more importantly, re-index the project and check the two views again?

(Please note, this is even more of a long-shot than before, I don't expect much.  I'm checking minutiae before Atlassin can confirm bugs)

Randy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 25, 2019

Did atlassian give us back the ability to re-index?  I thought they removed that ability on cloud?

Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Jul 25, 2019 • edited

Ah, I forgot, Cloud, yes, you can't re-index still.

You can force an issue to be re-indexed though - edit it (just add a . to a text field or something)

Like Randy likes this
Randy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 25, 2019

Thanks for the tip nic! didnt realize that.

Hi
Any solution of above problem, i am also facing same issue.

0 votes
Kathy Hart
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Sep 30, 2019 • edited

This is going to sound unrelated, but . . . it may be that you have too many ticket types available in your project. 

I had newly created tickets that did not show up in the Open Tickets filter just like you. They were in a project that I use for testing all the tickets types with all different kinds of workflows and screens etc. 

The issue only seemed to affect Document ticket types for which I was building a new workflow. I tried everything to fix the workflow. They were newly created tickets so there was no resolution set. They clearly showed unresolved, but would not show up in the filter. 

I had an issue once before using a default issue type scheme that showed every ticket type that was ever invented as part of the scheme. It reached a point where it wouldn't show all the ticket types. 

So . . . 

In my project with the unresolved ticket problem, I decided to cull down the available ticket types in half. 

And PRESTO . . . 

The tickets I had created before are now showing up in a filter for all open tickets. 

That fixed my problem. I hope it helps with yours. If there are any ticket types you don't use, remove them from your Issue Type Scheme in Admin. 

0 votes
Randy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 22, 2019

Are you saying that if you uncheck that checkbox in the screenshot, you see issues with blank resolutions?  Can you screenshot an example of one?  

Yes. That's exactly the case. See the screenshot below.

Screen Shot 2019-07-22 at 4.35.36 PM.png

Like Randy likes this
Randy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 22, 2019

Seems like a bug with Jira.  Can you try adding the Resolved field as a display column and see if there's any value set there for those 3 issues?  

Randy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 22, 2019

Another thing to check would be to clear the assignee check (the 4th item that says Current User) while keeping Unresolved checked.  If issues return then that could help narrow down the issue.

If you look at the screenshot, "Resolution" is already a display column and no data is displayed in the column.

The "Assignee" filter has nothing to do with the issue. It all works properly and displays as it is supposed to. If I uncheck the "Assignee" field, it displays the several hundred issues assigned to other users.

Also, to note, the "Unresolved" issue only seems to apply to these new issues I've created as part of my new workflow. There's other issues that exist that filter correctly based on the "Unresolved" filter.

For example... see the attached screenshot. Other issues created through other workflows correctly show the "Unresolved" resolution. It has nothing to do with the Assignee of the field.

Screen Shot 2019-07-22 at 4.54.04 PM.png

Randy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 22, 2019

Resolved is different from Resolution.  It's a date field.  I'm wondering if it got set and is considered as part of checking resolution.  I dont think it does but it would be something to check.  Resolved is set automatically when resolution is set.

Randy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 22, 2019

By chance is resolution being set to an empty string via some script or default setting on create?  Resolution being set to an empty string would be different from resolution being unset.

I just added the "Resolved" column an it shows blank.

There's no additional script that has been added and I haven't added any settings I'm aware of that should be changing the value of Resolution.

The only post functions on the create are the standard ones:

  1. Creates the issue originally.
  2. Move up Move down Edit DeleteRe-index an issue to keep indexes in sync with the database.
  3. Move up Move down Edit DeleteFire a Issue Created event that can be processed by the listeners.

Additionally, to note, as an experiment, I tried adding the "Update Issue Field" post function to the "Create" transition and setting the "Resolution" to "None" and also tried adding the "Clear Field Value" post function  to the "Create" transition for the "Resolution" field. Both ended up with the same result as without.

Randy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 23, 2019

Sounds like a bug with Jira or maybe an indexing issue.  Have you opened a ticket with atlassian support?  

If it was a bug in JIRA, I feel like the other issues created in this instance of JIRA would be doing the same thing rather than just the issues created in my specific project/workflow.

I lean a bit towards it being more something that I'm doing wrong rather than a bug. But, I'm also opening up a ticket with Atlassian Support as well.

Like Randy likes this
Josh_Kochelek__Modus_Create
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 25, 2019 • edited

@Country Sam - Have you found a solution here? If not, what's going on with the new workflow? Does it have ANY interaction with the Resolution field? Any post-functions clearing the resolution?

Also, is this workflow for a new project or an existing project? Are the project/issue types that are associated with the new workflow using a new or shared field configuration scheme?

Also have you edited the resolution values at all? Or are they out of the box? 

If it's not a bug, then maybe there is something new/different about these issues. Just trying to hash out what that is.

Kathy Hart
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Sep 30, 2019

I also have newly created tickets that do not show up in the Open Tickets filter. I'm using a custom workflow, but I don't have any resolution settings triggering then the issues are created.

Those tickets will not show up in any search with any resolution selected, so the tickets are not "set" to a specific resolution. They will not show up if you use the advance "resolution is EMPTY" search either.

Removing the Resolution filter from the query lets them show up on the list. Apparently this is a bug. Is there Support ticket on this issue yet? 

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events