Why is my spell check not working in HipChat for Linux?

I'm currently using hipchat-2.2.1388-x86_64.pkg.tar.xz on Gentoo Linux. Under HipChat > Settings, Spell check is enabled, yet I have no spell checking in any of my chats (no red lines for misspelled words). It looks like HipChat comes with its own version of HunSpell.

My $LANG environment variable is set to "en_NZ.utf8" I've also tried exporting my LANG to "en_US" in a shell and executing HipChat. Still no spell check. No ouput on the console either.

How do I diagnose why HipChat spell check isn't working?

6 answers

Not sure if this is a 'correct' fix, but it did get spell check working on my client. I noticed all files were installed to /opt/HipChat4 owned as root:root. I chowned that entire directory as my user/group, logged out of HipChat client, restarted HipChat client, logged in, and sent a message. Spellcheck now works and seems to have not impacted any client functionality. You might have to repeat these steps after a version upgrade, I did not test that.

chown -R <user>:<group> /opt/HipChat4

This workaround worked for me too, but I only changed the owner (chown -R <user> /opt/HipChat4)

Funny thing is, since I don't like having files for a program be owned by my own user, I changed it back doing chown -R root /opt/HipChat4. So maybe it's not a question of being owned by the logged-in user, but a question of all files being owned by the same user.

Thanks to your answer, I finally got spell check working.

I checked to see why the problem happened and found that in order for spell check to work, it needs to create a file at /opt/HipChat4/lib/qtwebengine_dictionaries/en-US-6-1.bdic. Since the installation has the entire /opt/HipChat4 directory owned by root, the executing HipChat client cannot create the file.

As suggested by Matthias, after I ran HipChat with the directory owned by my user, I then changed the ownership back to root. This is because the file was created and the write permissions are no longer needed.

It looks like Google Chrome uses the same dictionaries. To avoid this issue, Chrome stores the directories in $HOME/.config/google-chrome/Dictionaries/. It seems that the Linux HipChat client needs to be updated to supply a similar path to QT so that it stores the dictionaries in user-writable location.

Same for Debian, Ubuntu and Fedora with GTK-based DEs. 

Same here on arch, installed from https://aur.archlinux.org/packages/hipchat/ running KDE

Same issue Ubuntu 16.

Same using HipChat4 on Ubuntu 16.04. My locale in Linux is set to en_US.UTF-8.

When I run with --logtofile option, I get this:

hello 0.211871
[0513/085406:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
--type=zygote
hello 0.224435
Installed Qt WebEngine locales directory not found at location /opt/HipChat4/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /opt/HipChat4/lib/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
Installed Qt WebEngine dictionaries directory not found at location /opt/HipChat4/qtwebengine_dictionaries. Trying application directory...
[0513/085406:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale

The files referenced do not exist, but qtwebengine_dictionaries does exist under /opt/HipChat4/lib.

 

This fixed my issue. I didn't want a single user owning system files.

sudo chmod o+w -R /opt/HipChat4

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 10, 2018 in Hipchat

What should I think about when migrating HipChat to Slack?

...from the beginning. We have built up a lot of content in HipChat, with it being a core tool in our distributed company model. While it is true that we didn’t need to move to Slack immediately, we felt it...

506 views 1 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you