Spell check and slash commands

I didn't see this in any community questions but I'm noticing that the substitute slash command fails when spell check is enabled on the OSX client. The initial "s" gets capitalized and the command fails.

Ok, it's fairly trivial but a little annoying just the same. Is this correctable or is it a system level change? I prefer having initial sentence caps on by default (because I'm lazy). Thanks

1 answer

1 accepted

1 vote
Accepted answer
Shayne Covey Atlassian Team May 25, 2017

I haven't been able to reproduce the specific behavior you're referring to, but the HipChat client does have some options you can try changing.

CTRL-clicking on your chat bar will open an option tree that may help. The 'Spelling and Grammar' >> 'Correct Spelling Automatically' may be a good place to start.

Here's a screenshot, for clarity:

spellcheck_macos_hipchat.png

Genius, thanks. I had Correct Spelling Automatically checked. I unchecked it and my slash commands are no longer modified.

Cheers!

Shayne Covey Atlassian Team May 26, 2017

Excellent!

Since that did the trick, could you mark the answer as accepted, in case anyone else stumbles on the same problem?

Done. Thanks again Shayne

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 14, 2018 in Hipchat Cloud

Hipchat Cloud and Stride End of Life: Just over 90 days away

Earlier this year we made the difficult decision to discontinue our team messaging tools, Stride and Hipchat. The end of life date for Stride and Hipchat Cloud is quickly approaching - February 15, 2...

554 views 0 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you