Outgoing webhook returns an empty request

Hi. Help me please!

In my addon descriptor, I set a webhook handler as in the example:

"webhook": [{
          "url": "https://mysite.com/hipchat/echo.php",
          "pattern": "^/[eE][cC][hH][oO]",
          "event": "room_message",
          "key": "echo_message",
          "authentication": "none",
          "name": "Echo"

But after installing the add-on, and after sending command "/echo", my script "echo.php" does not receive any data, only empty request. Why?

1 answer

1 accepted

1 vote

Hi, could you check what data is being sent? You can use http://mockbin.org/ service to define the url for the webhook and it will show you the payload when the webhook is triggered.

Hi Anatoli. Many thanks, this service has helped to solve the problem! I wrongly tried to get data in $_POST and $_REQUEST. Correctly use

$entityBody = file_get_contents('php://input');

Suggest an answer

Log in or Join to answer
Community showcase
Maarten Cautreels
Published Oct 07, 2017 in Hipchat

Bringing Structure to your HipChat Instance

...have mention name FirstnameLastname. Fe.: @MaartenCautreels This certainly helps to know who is being mentioned in a conversation. Imagine your colleague sends the following message...

461 views 1 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot