Installing on Ubuntu 18.04

Hello,

Are you guys planning on adding a release file for your hipchat Ubuntu repository for bionic (18.04)?

At the moment, following your instructions results in an error:

E: The repository 'https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

8 answers

Run these commands to create new symlinks an you should be fine.

sudo rm /opt/HipChat4/lib/libcrypto.so*

sudo ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /opt/HipChat4/lib/libcrypto.so.1.0.0

sudo ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 /opt/HipChat4/lib/libssl.so.1.0.0

The original problem was not being able to install due to missing release file. One of my attempts was to change the release in the apt source file to artful and while it did install successfully and the HipChat client started alright, I couldn't login.

Your suggestion here helped me solve that problem, but the release file is still missing AFAIK. Thanks for your helpful comment, though!

I can't install it as well, and for me this does not work because all the files you remove and symlink don't exist.

 

So does anyone have gotton the installation to work yet?

Provided instructions worked for me,  thank you@Matt Sweeney

If I haven't installed HipChat yet because:

$ sudo apt-get update
Hit:1 http://se.archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://se.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:3 http://se.archive.ubuntu.com/ubuntu bionic-backports InRelease
Hit:4 http://security.ubuntu.com/ubuntu bionic-security InRelease
Ign:5 https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client bionic InRelease
Err:6 https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client bionic Release
404 Not Found [IP: 52.86.11.106 443]
Reading package lists... Done
E: The repository 'https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

then I cannot create symlinks to the non existent files:

$ sudo rm /opt/HipChat4/lib/libcrypto.so*
rm: cannot remove '/opt/HipChat4/lib/libcrypto.so*': No such file or directory
$ sudo ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /opt/HipChat4/lib/libcrypto.so.1.0.0
ln: failed to create symbolic link '/opt/HipChat4/lib/libcrypto.so.1.0.0': No such file or directory
$ sudo ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 /opt/HipChat4/lib/libssl.so.1.0.0
ln: failed to create symbolic link '/opt/HipChat4/lib/libssl.so.1.0.0': No such file or directory

 How do we get passed this?

I am having the same issue. I can't install on Ubuntu 18.04.

If you're following the instructions on the downloads page, open your /etc/apt/sources.list.d/atlassian-hipchat4.list file and change bionic to xenial

sudo apt-get update && sudo apt-get install hipchat4

then create the symlinks @Matt Sweeney posted in his comment above.

This got me working on 18.04 64-bit desktop.

Phillip,  Thank you this worked for me too!

Philip and others, thanks!

This is all I have been using to successfully start HipChat4:

Like 1 person likes this

This one works :)

Same here, I was missing the link "libssl.so" for hipchat to work with the Xenial version on the Bionic distribution :)

 

Thanks for pointing that one out,  sugalvojau !

Worked for me as well, although the 4th from the last step did not work.  Nevertheless, I'm up and running on Kubuntu 18.04.  Thanks.

Phillips, Thansk a lot

Thanks sugalvojau NA

Aswini Padala I'm New Here Tuesday

Thanks a lot Phillip

Same problem here:

Ign:5 https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client bionic InRelease
Err:6 https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client bionic Release
404 Not Found [IP: 54.164.30.90 443]
Reading package lists... Done
E: The repository 'https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

There appear to be two issues here:

1. There is no Releases file for bionic. I fixed that for now by replacing "bionic" with "xenial" in /etc/apt/sources.list.d/atlassian-hipchat4.list. Then I did "sudo apt update; sudo apt install hipchat4".

2. After installing, the hipchat4 executable doesn't connect. That's fixable by following the "ln" instructions above, or in this issue: https://jira.atlassian.com/browse/HCPUB-6249.

I got things running by doing both of the above (after having uninstalled hipchat4 during my upgrade from 16.04 to 18.04).

sudo sh -c 'echo "deb https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client stretch main" > /etc/apt/sources.list.d/atlassian-hipchat4.list'
wget -O - https://atlassian.artifactoryonline.com/atlassian/api/gpg/key/public | sudo apt-key add -
sudo apt-get update
sudo apt-get install hipchat4
sudo ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /opt/HipChat4/lib/libcrypto.so.1.0.0
sudo ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 /opt/HipChat4/lib/libssl.so.1.0.0
sudo ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 /opt/HipChat4/lib/libssl.so

 

@Ahmed Kamel Could you add the following to the script you posted:

sudo ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 /opt/HipChat4/lib/libssl.so


That made it finally work for me :)

Thanks to everyone who contributed to solving this!

0 votes

Hi, Yosi!

This is related to a known issue, recently reported. Please check and follow for updates:

HCPUB-6379

Are you sure this is the same thing? The ticket seems to be about the yum repo while I'm referring to to Ubuntu Bionic apt repo...

I found a solution to this, that wors for me, instead of the suggested

sudo sh -c 'echo "deb https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client $(lsb_release -c -s) main" > /etc/apt/sources.list.d/atlassian-hipchat4.list'

I just use the release for stretch. That works also with the bionic beaver. So I do this instead:

sudo sh -c 'echo "deb https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client stetch main" > /etc/apt/sources.list.d/atlassian-hipchat4.list'

Thanks Georg, but that version has the same missing symbols as the Xenial one.

After applying Matt Sweeney's symlinks I still had the missing symbols, but googling the exact error took me to https://github.com/wkhtmltopdf/wkhtmltopdf/issues/3001 where someone points out that in Debian based distributions, the symbols are only available when libssl-dev is installed. That got Hipchat4 running for me on Ubuntu 18.04

The stretch package is not working for me on Bionic, keeps asking me for the URL.

Perhaps Atlassian staff can elaborate on when they'll have a bionic/snap/flat package available?

Edit: I see op questioned that already, but of course this is community driven, so no Atlassian staff @here..

Also https://jira.atlassian.com/browse/HCPUB-2070 seems related, it has my vote!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 14, 2018 in Hipchat Cloud

Hipchat Cloud and Stride End of Life: Just over 90 days away

Earlier this year we made the difficult decision to discontinue our team messaging tools, Stride and Hipchat. The end of life date for Stride and Hipchat Cloud is quickly approaching - February 15, 2...

531 views 0 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you