I'm receiving an incorrect auth_test response on the HipChat room/[id]/notification endpoint

I'm posting to the following endpoint:

room/[id]/notification

I'm passing my auth token and the auth_test: true parameter.

It appears as though room-only tokens respond with 202 for all of my rooms.

{"success"=>{"code"=>202, "message"=>"This auth_token has access to use this method.", "type"=>"Accepted"}}

I would expect it to only return 202 for the room the token was created for.

When I try to send a notification to each room, it works for the room the token applies to and returns 403 Unauthorized from the other rooms (as expected).

Is there something wrong with the auth_test endpoint?

0 answers

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Mar 26, 2018 in Hipchat Data Center

Migration of Hipchat server to Data Center - a retrospective

...able to use the clients After a bunch of testing (rooms, memberships, check for private message history, and most importantly - the custom emoticons!) nearly everything was looking as we needed, however...

455 views 2 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you