I'm receiving an incorrect auth_test response on the HipChat room/[id]/notification endpoint

I'm posting to the following endpoint:


I'm passing my auth token and the auth_test: true parameter.

It appears as though room-only tokens respond with 202 for all of my rooms.

{"success"=>{"code"=>202, "message"=>"This auth_token has access to use this method.", "type"=>"Accepted"}}

I would expect it to only return 202 for the room the token was created for.

When I try to send a notification to each room, it works for the room the token applies to and returns 403 Unauthorized from the other rooms (as expected).

Is there something wrong with the auth_test endpoint?

0 answers

Suggest an answer

Log in or Join to answer
Community showcase
Maarten Cautreels
Published Oct 07, 2017 in Hipchat

Bringing Structure to your HipChat Instance

...have mention name FirstnameLastname. Fe.: @MaartenCautreels This certainly helps to know who is being mentioned in a conversation. Imagine your colleague sends the following message...

461 views 1 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot