It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to enable presence status in HipChat for Confluence plugin?

I am seeing the integration at the Space Admin level, but I am not seeing presence status that is expected with the addition of this plugin. Is a restart required or do I have to use V2 BETA API with HipChat potentially?

(See screenshot example of expected precense status icon here: https://bitbucket.org/atlassian/hipchat-for-confluence)

1 answer

1 accepted

1 vote
Answer accepted
David Maye Atlassian Team Aug 20, 2014

Hi Brent,

There shouldn't be a restart required as the plugin should work once the settings are configured. In my testing, the presence showed up with the user card. The API v1 token should be the correct one to use.

Are you getting notifications in HipChat when a new page is created in Confluence? Are you using Confluence OnDemand or Server?

A few things I would double check: your token, make sure it's valid (should be 30 characters long) and change the base URL to api.hipchat.com(if it isn't set already). What I found is that the status sometimes takes a short amount of time to show up, so maybe the better test would be to configure a room to receive a notification, then create a test page and see if the notification populates in the room.

Cheers,
-David

Hello David,

Thanks for the info and confirming the configuration becomes live immediately. Originally when I setup with a V1 admin token I saw the integration for page updates was available (showed up on the Integrations tab in Space Admin and I saw the list of rooms), but did not try to actually to post to any rooms. The awareness wasn't working, but I just realized what was going on --> the awareness feature is sensitive to using the configured site URL when accessing Confluence. (I had started to test/use a SSL-enabled URL for Confluence while our site URL is still pointing directly to the app server.)

I went back into Confluence in a clean browser with the current site URL and re-setup the Hipchat API as that had broken somehow. After putting in the new token and giving it a few minutes, I now see awareness is working.

Time to bite the bullet and get that site URL updated. Seems it shouldn't be too difficult to the users as long as we let them know to verify they are using the right base URL.

Thanks again

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Hipchat

Hipchat Cloud and Stride have reached End of Life (updated)

All good things come to an end - thanks to all our customers and partners who have been along the Hipchat and Stride journey with us.  As of Feb 15th 2019, Hipchat Cloud and Stride have reached ...

35,201 views 9 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you