Hipchat cannot purge exports

This is normally done remotely with the script 'hipchat_server_remote_exporter.sh', but for testing I ran it on the hipchat server directly and I got the same result.

admin@hipchat:~$ /opt/atlassian/hipchat/sbin/hipchat export -u 4
Couldn't delete 53ec9e82-6cb5-4491-846d-d74eef9a6587, please look at the hipchat logs for more information: ('Connection aborted.', BadStatusLine("''",))

I did take a look in the "hipchat logs", but there is so much other noise in 30-some log files and I don't know what I'm looking for.

Any advice?

1 answer

1 accepted

0 vote
Arbi Dridi Atlassian Team Jun 29, 2017

Hi there, 

This is a known bug in versions earlier than 2.2.3 that use Cumulus for file storage: HCPUB-2981 - Exports do not purge

Please upgrade to the latest HipChat Server version.

Thanks. 

That explains it, thank you. I completely forget to check for Issues.

The workaround given in the Issue solves my problem until we can upgrade.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Mar 26, 2018 in Hipchat Data Center

Migration of Hipchat server to Data Center - a retrospective

...able to use the clients After a bunch of testing (rooms, memberships, check for private message history, and most importantly - the custom emoticons!) nearly everything was looking as we needed, however...

453 views 2 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you