It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Hipchat Data Center setup wizard doesn't finish

Mariana Schiff Jul 05, 2018

We're evaluating Hipchat Data Center for our internal communications, and also as the engine behind custom chat functionality within an internal website with no internet access. We're planning on using the REST API from our website.

For a quick evaluation and proof-of-concept setup, I decided to use a VirtualBox server running Ubuntu on a Windows 7 host for the HipChat server, the host machine for PostgreSQL and Redis, and a Windows Server 2012 R2 for the NFS server. Aside from these servers, we're disconnected and have no internet access.

The setup wizard runs fine through configuring the PostgreSQL and Redis servers. It was failing to mount the NFS share until I edited the mount_shared_storage.sh script and changed 'vers=4' to 'vers=4.1' in the OPTIONS variable. The NFS server on Windows only supports versions 2, 3, and 4.1.

After I entered all my data and the trial license on the last screen of the wizard, now it's taking a long time to run. It seems to be doing something, because I see requests being fired off from the browser. The address on the browser is https://<server>/setup/setup_welcome_3. It has been an hour now and counting. Using a different browser, both the host and the /chat/ urls redirect to the wizard.

The certificate is the same that came with the Ubuntu hipchat image I downloaded. The fqdn key is not yet on the configurations table in the database.

Is this normal? Is there a log I could check? Thanks in advance for any suggestions.

2 answers

1 accepted

1 vote
Answer accepted
Mariana Schiff Jul 10, 2018

To help others who may encounter a similar issue, the log that helped us the most was /var/log/hipchat/nginx.err.log. Beware: it's hard to read without reformatting it.

Details of what we did above.

Thanks!

Ahmad Danial Atlassian Team Jul 19, 2018

Hi, Mariana.

Thank you too for sharing! 

0 votes
Ahmad Danial Atlassian Team Jul 05, 2018

Hi, Mariana.

While we have the How to re-enable the setup wizard in Hipchat Data Center, let us try to understand the issue here better before considering the solution there.

In terms of logs, can we check on the following logs to see what the deployment is doing at the backend:

  • /var/log/hipchat/web.log
  • /var/log/hipchat/kern.log
  • /var/log/hipchat/nginx.log
  • /var/log/hipchat/tetra.log
  • /var/log/hipchat/hup.log

Some questions that I have:

  • Can you share with us if there are any lines that shows error so we can start troubleshooting this issue?
  • What is the IP / URL you use to access the setup wizard on the web browser since you mentioned that FQDN is not configured yet?
  • Additionally, can you provide me with the output of hipchat datacenter selfcheck as well? 
  • Do you have the proxy / load balancer configured yet?
Mariana Schiff Jul 06, 2018

Hi, Ahmad, thanks for your reply.

We were able to work through several problems:

  1. We noticed a message when the hipchat server started that it couldn't find "hipchat.example.com". Editing /etc/hosts didn't help because it kept getting overwritten. So we changed the hostname to simply "hipchat" and that cleared that error.
  2. Digging through logs we saw that it couldn't connect to the Postgresql database. Our password had an '@' sign, and that character was being used as a delimiter in the connection string. After changing the password, we deleted /hipchat/config/site.json, restarted the hipchat service, and that allowed us to get to the first page of the wizard, where we entered the new database information.
  3. Now it couldn't connect to Redis. We changed the Redis setup to not require a password, and restarted the Redis server. In order to access the second page of the wizard, we recreated the Postgresql database and restarted the wizard as above. Then we were able to setup Redis without a password on the wizard.
  4. Finally the wizard ended, but we couldn't login. We had been using IE all along. On a hunch, we tried from Chrome and then it worked.

I have no idea why IE doesn't let us login. We'll have to solve that problem because it's our company's default browser. But the good news is that hipchat is now up and running, usable through Chrome.

Ahmad Danial Atlassian Team Jul 08, 2018

Hi, Mariana.

You are welcome and thank you too for sharing the detailed steps you performed to ensure that HipChat Data Center is now up and running. I suspect the reason why we run into issues with Internet Explorer is due to the fact that it is not listed as a supported platform in the official documentation here - Browser Based Clients - which states that only Microsoft Edge (Windows specific) is supported.

Therefore, is it possible for you to have this tested on Microsoft Edge as well to verify if you also run into the same issue? It is not necessary but I figured that you might be interested to go a little bit deeper in this matter.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Hipchat Cloud

Hipchat Cloud and Stride have reached End of Life (updated)

All good things come to an end - thanks to all our customers and partners who have been along the Hipchat and Stride journey with us.  As of Feb 15th 2019, Hipchat Cloud and Stride have reached ...

33,325 views 7 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you