Fedora 27: Segmentation fault on start Edited

I just installed the new Fedora 27 and unfortunately hipchat4 crashes immediately on startup.

  
This is the console output:
 
hello 0.314792
PackageLocation: "/opt/HipChat4/share/localweb/package.json"
package.json opened
package.json valid
package.json object
package.json version value = "4.29.4"
Reading config.ini file
force_server= false value= ""
Qt WebEngine ICU data not found at /opt/HipChat4/lib/resources. Trying parent directory...
Installed Qt WebEngine locales directory not found at location /opt/HipChat4/lib/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /opt/HipChat4/lib/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
Qt WebEngine resources not found at /opt/HipChat4/lib/resources. Trying parent directory...
[0721/231839:ERROR:resource_bundle.cc(720)] Failed to load /opt/HipChat4/lib/qtwebengine_devtools_resources.pak
Some features may not be available.
[0721/231839:WARNING:resource_bundle.cc(311)] locale_file_path.empty() for locale
[0721/231839:ERROR:browser_main_loop.cc(217)] Running without the SUID sandbox! See https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the sandbox on.
--type=zygote
hello 0.569669
Qt WebEngine ICU data not found at /home/tm/Qt/5.7/gcc_64/resources. Trying parent directory...
Qt WebEngine ICU data not found at /home/tm/Qt/5.7/gcc_64. Trying application directory...
Installed Qt WebEngine locales directory not found at location /home/tm/Qt/5.7/gcc_64/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /opt/HipChat4/bin/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
Qt WebEngine resources not found at /home/tm/Qt/5.7/gcc_64/resources. Trying parent directory...
Qt WebEngine resources not found at /home/tm/Qt/5.7/gcc_64. Trying application directory...
[0721/231839:ERROR:resource_bundle.cc(720)] Failed to load /opt/HipChat4/bin/qtwebengine_devtools_resources.pak
Some features may not be available.
[0721/231839:WARNING:resource_bundle.cc(311)] locale_file_path.empty() for locale
[21:18:39][void HipChatApplication::initialize(HipChatApplication::Configuration&):393] datapath "/opt/HipChat4/lib"
[21:18:39][virtual bool OnlineStatus::platformSpecificHasInternetConnectivity():38] org.freedesktop.NetworkManager interface is valid
[21:18:39][void AbstractOnlineStatus::checkOnlineStatus():196] platform online state = true
[21:18:39][void AbstractOnlineStatus::doSecondaryCheck(bool):205] Do secondary online check
[21:18:39][void AbstractOnlineStatus::doSecondaryCheck(bool):259] onlineStatusUrl is empty
[21:18:39][void AbstractOnlineStatus::handleOnlineStatusResult(bool):171] newOnlineState: true
[21:18:39][void AbstractOnlineStatus::handleOnlineStatusResult(bool):184] initCheckComplete
[21:18:39][void HipChatApplication::onInitialOnlineCheck(bool):307] HCA isInitOnline: true
[21:18:39][void HipChatApplication::onInitialOnlineCheck(bool):310] doAuth
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve CRYPTO_num_locks
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve CRYPTO_set_id_callback
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve CRYPTO_set_locking_callback
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve ERR_free_strings
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve EVP_CIPHER_CTX_init
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve sk_new_null
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve sk_push
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve sk_free
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve sk_num
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve sk_pop_free
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve sk_value
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve SSL_library_init
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve SSL_load_error_strings
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve SSL_get_ex_new_index
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve SSLv2_client_method
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve SSLv23_client_method
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve SSLv2_server_method
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve SSLv23_server_method
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve X509_STORE_CTX_get_chain
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve SSLeay
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot resolve SSLeay_version
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot call unresolved function CRYPTO_num_locks
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot call unresolved function CRYPTO_set_id_callback
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot call unresolved function CRYPTO_set_locking_callback
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot call unresolved function SSL_library_init
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot call unresolved function SSLv23_client_method
Warning: [21:18:39][qt.network.ssl][:0] QSslSocket: cannot call unresolved function sk_num
 
Any advice?

3 answers

1 accepted

Fixed following these instructions: 

cd /opt/HipChat4/lib
ln -s /usr/lib64/libcrypto.so.10 libcrypto.so
ln -s /usr/lib64/libgcrypt.so.20 libgcrypt.so
ln -s /usr/lib64/libssl.so.10 libssl.so

 

Hi Roberto, It happened to me as well, and this is fix also with those command. Thank you very much.

Now that Fedora 27 is shipping OpenSSL 1.1, HipChat won't work at all. To get it to work now, you must:

  dnf install compat-openssl10-devel

With hipchat4 4.30.4.1672 no extra workarounds are needed (e.g., no symlinking).  

Hi Roberto,

at day 2 of Fedora 27, libgcrypt.so.20.1.8 is no more (don't know if updated or else), so instructions are to be modified. Wouldn't it be better to point to libgcrypt.so.20 (which will get updated when library is updated).

also these upgraded too

libssl.so.1.0.2m

libcrypto.so.1.0.2m

Hi Luca, thanks for the suggestion, I've updated my answer.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 10, 2018 in Hipchat

What should I think about when migrating HipChat to Slack?

...from the beginning. We have built up a lot of content in HipChat, with it being a core tool in our distributed company model. While it is true that we didn’t need to move to Slack immediately, we felt it...

499 views 1 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you