fisheyectl command line options

Options like --Xenable-git-content-hash-resolving-heuristic don't seem to be picked up using "./fisheyectl.sh start--Xenable-git-content-hash-resolving-heuristic", but they are being picked up as a fisheye option (per the log) using ./fisheyectl.sh run --Xenable-git-content-hash-resolving-heuristic. Can anyone reproduce this?

4 answers

1 accepted

This widget could not be displayed.

I closed this ticket after nothing could be determined; I manually added the option to fisheyectl.sh (line ~55) and now it works.

nohup sh -c "exec $FISHEYE_CMD $@ --Xenable-git-content-hash-resolving-heuristic $FISHEYE_ARGS >> $FISHEYE_INST/var/log/fisheye.out 2>&1" &

This widget could not be displayed.

I've never heard of this, but to be sure I just tried it out with FishEye 2.10.4 on OSX.

Both "./fisheyectl.sh start" and "./fisheyectl.sh run" indeed pick up the "--Xenable-git-content-hash-resolving-heuristic" argument just fine for me.
The atlassian-fisheye-yyyy-mm-dd.log shows that this happens in both cases.

Which version are you running?
Can you post the logfile lines that show that the argument is not picked up when running "start" ?

Sure. Here's the screen output when I use run -

[snip]/bin$ ./fisheyectl.sh run --Xenable-git-content-hash-resolving-heuristic

2013-04-21 16:45:03,227 INFO - Using log4j configuration file: [snip]/log4j.xml

2013-04-21 16:45:03,249 INFO - FishEye arguments: [--Xenable-git-content-hash-resolving-heuristic]

2013-04-21 16:45:03,251 INFO - Starting with --Xenable-git-content-hash-resolving-heuristic. Revisions in file tab of repository browser may be incorrect.

2013-04-21 16:45:03,252 INFO - FishEye/Crucible 2.10.4 (20130403093648), Built on 2013-04-03

Here's the fisheye log from the home dir when I use start:

[snip]/bin$ ./fisheyectl.sh start --Xenable-git-content-hash-resolving-heuristic

2013-04-21 16:47:09,742 INFO [main ] fisheye BaseCommand-setupLogging - Using log4j configuration file: [snip]/log4j.xml

2013-04-21 16:47:09,765 INFO [main ] fisheye BaseCommand-handleCommonArguments - FishEye arguments: []

2013-04-21 16:47:09,767 INFO [main ] fisheye Run-sysinfo - FishEye/Crucible 2.10.4 (20130403093648), Built on 2013-04-03

I assume from the differences in the logs that it's not picking up the arguement; it's a hard option to verify if it's enabled or not, though.

-Kelly

This widget could not be displayed.

Like Rene, I've run a quick test and this works for me. Can you confirm that the fisheyectl script has not been modified?

One thing to do is to run the script with sh -x, i.e.

sh -x bin/fisheyectl.sh start --Xenable-git-content-hash-resolving-heuristic

and see what the script is doing. Is it passing the argument along correctly?

If the problem remains, could you give us some info on your platform?

It's hard to confirm it hasn't been modified, but it has the exact same time/date stamp as all the other files in bin. I don't remember modifying it when I installed 2.10.4.

I tried sh -x and it spit out a tremendous amount of debug information, but the result is still the same, it still says options are empty.

It's an Ubuntu 64-bit 12.04.02 LTS server. Where can I send the debug output? Should I convert this to a support ticket, since you don't want me to keep sanitizing the bits I paste here, and I don't want to paste folder structures and additional server information publically.

Interestingly, in the middle of the debug block is this fragment:

fisheyeboot.jar start --Xenable-git-content-hash-resolving-heuristic >>

So it's picking up that I'm typing it. Is there a way to tell elsewhere if it's enabled?

This widget could not be displayed.

I think creating a support ticket is a good idea at this point. I'd suggest putting a link to this topic into your support request

According to the support ticket, it has been raised as a bug for Linux only: https://jira.atlassian.com/browse/FE-4639

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted 3 hours ago in Statuspage

What are your best incident management tips and stories? #HugOps

 👋Community members! Downtime happens. And great incident response takes a village. Teams like Support, Dev, SRE, Ops, IT, and Marketing have to come together to resolve the problem while keep...

19 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you