fisheye/crucible installation problem

Hi, 

I am trying to follow the here be dragons tutorials so I can install the evalution of the products. I am installing on a ubuntu box

On stage 5, in fisheye/crucible installation, there is a step to change config.xml and add context="/fisheye". I did this only in the config file in the data directory. The file in the root directory was left as is. 

When I got to step 6, to add the gadget to JIRA dashboard I noticed that the url for fisheye server was http://machine:8060 and not http://machine:8060/fisheye as I suppose was correct.

In stage 7 I was not able to add the crucible dashboard. The server url is http://machine:8060 and the chart does not show up.

Was I supposed to change config.xml in both directories in stage 5? Is there a way to fix the configuration without starting all over?

2 answers

1 accepted

Accepted Answer
0 votes

Kelly,

Based on your latest comment I believe that FishEye is not getting your data directory properly. Please check this by going to FishEye Administration > System Info and confirm if FISHEYE_INST points to your data directory. If it is pointing to your install directory then it means that FishEye is using the config.xml under the install directory.

In order to have the data directory properly picked by FishEye, its location must be set in the FISHEYE_INST environment variable. Please confirm you have this and the user running FishEye can see it (you may test by executing an "echo $FISHEYE_INST" command).

Regards,

Gustavo Refosco

Hi Kelly,

When setting a context path you also need to set this in FishEye's Site URL. This can be done by setting the site-url within the web-server tag, so it would be as follows:

<web-server context="/fisheye" site-url="http://machine:8060/fisheye">

This only needs to be set in the config.xml that's under the data directory (as the one under the install directory will be ignored).

Please check how it goes after specifying the Site URL.

Regards,

Gustavo Refosco

It doesn't seem to have worked. I restarted everything. Dropped all databases and started over. When I got to stage 5, my data directory for fisheye is /opt/fisheyecrucible and the installation is in /opt/fecru- My config.xml in the data directory is this: <config control-bind="127.0.0.1:8059" version="1.0"> <!-- see example-config.xml and config.xsd for more documentation --> <web-server context="/fisheye" site-url="http://10.1.1.150:8060/fisheye">; <http bind=":8060"/> </web-server> <security allow-anon="true" allow-cru-anon="true"/> <repository-defaults> <linker/> <allow/> <tarball enabled="false" maxFileCount="0"/> <security allow-anon="true"/> </repository-defaults> </config> But when I point my browser to http://10.1.1.150:8060/fisheye, I get The requested resource cannot be found. If I go to http://10.1.1.150:8060 I get the fisheye page. But this is the same situation that led me to an error the first time.

After the steps of getting a evaluation licence, I noticed that the config.xml that is under the intallation directory does not have the context or site-url I added in the file in the data directory, but, it has a licence key. Is it supposed to be this way?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published 8 hours ago in Jira Ops

Jira Ops Early Access Program Update #1: Announcing our next feature and a new integration

Thanks for signing up for Jira Ops! I’m Matt Ryall, leader for the Jira Ops product team at Atlassian. Since this is a brand new product, we’ll be delivering improvements quickly and sharing updates...

146 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you