It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira -> Crucible, User Administration Question

Andrew Murdoch Jul 11, 2016

Hey Guys

So I have a JIRA server up and running with users and projects and all that wonderful stuff.  I just downloaded Crucible for code reviews and setup an application link between JIRA and Crucible, and setup the user directory in Crucible to pull from the JIRA server.   I can see the JIRA users inside Crucible, but when I click the name of a user from the JIRA user database, I see a red box which says "no access".

I can't figure out how to activate a user in JIRA so they can login in Crucible, has anyone got this working?

4 answers

1 accepted

0 votes
Answer accepted
Marek Parfianowicz Atlassian Team Jul 11, 2016

Check if your user belongs to the 'crucible-users' and 'fisheye-users' groups (Administration > User settings > Users).

Check if 'crucible-users' and 'fisheye-users' groups have the 'FishEye & Crucible user' and 'FishEye user' access (Administration > Security > Global permissions).

References:
Andrew Murdoch Jul 12, 2016

Thanks

i tried that yesterday and it didn't work, however when I tried it right now, it accepted the user.  I assumed that Fisheye / Crucible, would of showed up under Application and Groups. 

Anyway thanks for the help, no idea why it worked this time and not before, maybe a synchronization problem.

1 vote
Marek Parfianowicz Atlassian Team Oct 16, 2018

In case you use external user directory, then you may be also affected by this bug:

User's permissions are not refreshed if the user is being automatically added to a group in external directory and this group controls global permissions

https://jira.atlassian.com/browse/FE-7001

0 votes
Sonny Singh Oct 16, 2018

Hi guys.

 

I had the same problem on Jira Software DC 7.11.1. 

 

I removed the specific user from Fisheye-users in Jira, synced Fisheye user directories(in Fisheye), added user back to Fisheye-users in Jira, synced Fisheye user directories and then he got access :-)

0 votes
Cody Stott May 02, 2019

I'm using a JIRA Directory and Global Permissions to Fisheye/Crucible are granted through a group.

I got around this bug by explicitly adding the users in that group to the Global Permissions instead of relying on the group.

Vasu Lingegowda I'm New Here Friday

same here, works (only) this way for me too!

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Next-gen

Introducing subtasks for breaking down work in next-gen projects

Teams break work down in order to help simplify complex tasks. This is often done iteratively, with tasks being broken down into smaller tasks and so on until the work is accurately captured in well-...

1,593 views 14 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you