It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Fisheye svn repository indexing hangs

Hi Community:

I recently upgraded to Fisheye 3.2.4 and I was able to index all svn repositories except one. I have to admnit that this repository is too big. When I wanted to start automatically the repository, it didn't start, so I had (and still having) to make the initial index. While performing the initial reindex, it got stuck in one point (which I will provide later one.)

Indexing content: /file/path/at/the/subversion/repository.file (33873 of 33874)

I performed the following actions

1. Repository Indexing stuck

2. Use the fille:/// protocol, instead of using the http. (Note: The rest of the svn repositories are working fine with the http protocol).

Please, I need your help ASAP!!!!!

Thanks

6 answers

1 accepted

3 votes
Answer accepted

The problem was that at the repository, I left the Start Revision value as 1. In order to fix it, I needed to empty the field. Then, shutdown Fisheye and clear the repository cache. After start up Fisheye and it will be reindexing as normal

Lukasz Pater Atlassian Team Feb 20, 2014

Tracked as FE-5091

0 votes
Doreen Becker Jan 29, 2014

Do you get any messages in FishEye's log? Any Timeouts? Or OutOfMemory errors?

Or is the message "Indexing content: ..." the last one in your log file?

Logfile "fisheye.out" can be found at: <fisheye-data-directory>/var/log/

0 votes
There is nothing. While I was trying to stopthe repository the error at the log tells me the following : Timed out ro stop the (svn) repository. The approach that I ended up was shutdown Fisheye, delete the cache at $FISHEYE_INST/var/cache/repo and restart Fisheye. Still indexing hangs
0 votes
Doreen Becker Jan 29, 2014

We had a similar issue with a certain SVN repository (all other repos works fine), but actually we found a TimeoutException in our logs.

To understand which command of the indexing process runs too long to raise a TimeoutException, we looked into the "Status" view of the corresponding repository. This can be found in FishEye's Administration page at "Repository Settings" -> "Repositories". Search for the "evil" repository and click on cog-wheel icon. Select menu "view ...".

In page "Summary" we saw that one SCM activity took more than 1 hour:

svn proplist -R -r 18889 file:///svn/repos/MYPROJECT/tags/release-1.0@18889

With this information we could continue analyzing the error, because we run the same svn command in systems console. This shows us the actual problem and we could fix it (in our case with configuring a "path excluding pattern" in FE wich excludes this tags/release-1.0 path from scanning).

Maybe this helps you, too?

If the problem is a "simple" Timeout issue you can increase the timeout "Svn Operation Timeout" value at "SCM Details" page of the repo. I think the default is "1h".

0 votes

Is that revision the latest of your repository?

0 votes

Is that the latest revision of your repository?

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Opsgenie

Handling Opsgenie Alerts

Hi everyone, welcome to the kb articles for Opsgenie FAQs. I'm one of the Technical Support Engineers for Opsgenie who will be providing weekly posts on FAQs from customers.   All alerts are ...

56 views 0 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you