Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,299,290
Community Members
 
Community Events
165
Community Groups

Fisheye can't read ssh key

A few days ago, fisheye stopped indexing our repositories. When I run test connection, it gives a wierd message about it not being able to create the .ssh directory and that the identity file is not accessible. I've gone through the UI and recreated the ssh key and it can read and write it. The .ssh directory was originally created by fisheye and it hasn't changed. Any idea what's wrong?

Fisheye is using 'C:\Git\bin\ssh.exe' to authenticate with SSH authenticated repositories.

Error testing connection.
Error talking to repository:

Warning: Identity file c:\FISHEYE_INST\data\auth\Repo not accessible: No such file or directory.
Could not create directory 'u/.ssh'.
Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
fatal: The remote end hung up unexpectedly

at com.atlassian.fisheye.git.GitScmConfig.testConnection(GitScmConfig.java:143)
at com.cenqua.fisheye.RepositoryConfig.testConnection(RepositoryConfig.java:444)
at com.atlassian.fisheye.spi.admin.impl.DefaultRepositoryAdminService.testConnectionFor(DefaultRepositoryAdminService.java:553)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

Connection failed.

3 answers

1 accepted

0 votes
Answer accepted

Updating Git actually didn't fix it. It happened a few hours after the update. The reason why it looked like it fixed it was because there was a long running ssh command going that had to be killed to update Git. When the error occurred again, I just killed that long running ssh command and it worked again.

I believe what actually happened was I had changed the number of "Incremental Indexing Threads" from 1 to 3 a few days earlier. I changed that back to 1 and I've never seen the longing running ssh command or this error since.

0 votes

Hi Trevan,

The error

Warning: Identity file c:\FISHEYE_INST\data\auth\Repo not accessible: No such file or directory.

clearly explains the file c:\FISHEYE_INST\data\auth\Repo was not readable to the user running FishEye. I'm guessing that there were wrong permissions that were fixed when key pair was recreated. Can you let me know what FishEye version are you using? Just curious as the issue was fixed recently in FishEye 3.2.1 release: https://jira.atlassian.com/browse/FE-4984

Cheers,

No, that didn't seem to be what is happening. I actually deleted that old identity file and let Fisheye regenerate it. So it should have been able to read/write the file. Also, this error occurred over a weekend and the file had previously been working.

I updated Git for Windows and it is working now.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

270 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you