It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Dragons Repository. What does this mean?

Fri Sep 29 16:28:56 PDT 2017: Repository index failed due to error com.cenqua.fisheye.rep.RepositoryClientException: com.atlassian.fisheye.dvcs.handler.DvcsProcessException: Error while communicating with VCS: *** failed to import extension felog from D:\fisheyecrucible-3.7.0\fecru-3.7.0\python\hg\hgfelog\hgfelog.py: missing attributes: norepo, optionalrepo, inferrepo *** (use @command decorator to register 'fecheck') hg: unknown command 'felog' (did you mean log?) com.atlassian.fisheye.dvcs.handler.DvcsProcessException: Error while communicating with VCS: *** failed to import extension felog from D:\fisheyecrucible-3.7.0\fecru-3.7.0\python\hg\hgfelog\hgfelog.py: missing attributes: norepo, optionalrepo, inferrepo *** (use @command decorator to register 'fecheck') hg: unknown command 'felog' (did you mean log?) com.atlassian.utils.process.ProcessException: While executing: "C:\Program Files\TortoiseHg\hg.exe --config extensions.felog=D:\fisheyecrucible-3.7.0\fecru-3.7.0\python\hg\hgfelog\hgfelog.py --config ui.verbose=false felog 922fd9308885467fcb3ed0a3a185d8e661bedcc9 -p -m" in [D:\data\fisheyecrucible\var\cache\Dragons\clone] com.atlassian.utils.process.ProcessException: java.lang.NullPointerException java.lang.NullPointerException: null

3 answers

1 accepted

2 votes
Answer accepted

I just had a version of Mercurial that was too new for Fishey 3.7.0.  Installed the correct, supported version and now it works.

Downgrading resolve the problem. Thanks.

Nothing shows up in fisheye recent changesets either.

This is what it says on my JIRA dashboard:

 

There are problems with the current configuration for this gadget. The errors below may have been caused by the deletion of entities required by the gadget or by changes to your permissions.

  • Problem communicating with FishEye

Thank you, I ran into this error and other errors like it when the version of Mercurial was either too old/new. This version of Fisheye is very picky. I included the exact version of Mercurial needed at the link below. 

https://community.atlassian.com/t5/Fisheye-Crucible-questions/Trouble-at-Dragon-Stage-7-Step-2/qaq-p/844629

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira

Managing Incidents - The roof is on FIRE!

The roof is on FIRE… network outages, broken processes, upset clients and employees. Each day seemed to bring more and more issues. Incidents were communicated via email, messengers (skype or teams) ...

133 views 0 1
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you