Connecting to Git Repo from Fisheye


While trying to add an existing git repo, the connection to the repo fails if we have special characters in the password (especially @ symbol) when using Authentication style as "Password for http(s)". The returned error code is 401.

The connection works fine if the password has no special characters.

Any help on this behaviour and how it can be resolved?


6 answers

0 vote
Jeff Thomas Atlassian Team Dec 31, 2013

Try encoding the @ symbol in your password with %40. So if your password is 'P@ssword', it would become 'P%40ssword'.

That should be a safe way to encode the @ symbol in the URL that's being used.

Well that didnt help either :( . We got the same error when we tried that way. For now, we have created a dummy user that doesnt have such characters in its password, but the problem is still open.

Jeff Thomas Atlassian Team Jan 20, 2014

I just created a user in our Stash instance with a password of "stash@user" and connected Fisheye to that repository using the password without any issues. Which version of Fisheye are you using and where is the repository that you're trying to connect to hosted?

Our setup is rather simple. We have GIT installed on the same server as where the Fisheye is installed.

Trying to add a new repo and providing a password with @ symbol still doesnt work. Returns a 401. The username and password are correct. And it works when we give a username and password that doesnt have @. Our Fisheye is at 3.1.5

Even i am facing same issue . i am abel to connect using my account but not with generic account havin @ in pasword

0 vote
Nick Pellow Atlassian Team Apr 07, 2014

It is best practice not to embedd the password in your URL when connecting to a git repo from FishEye.

Is there any reason you can't use the SSH protocol and exchange public keys ?

Can you tell me how to do that . I am new to GIT

Nick Pellow Atlassian Team Apr 08, 2014

Where is your git repository hosted ?

* Stash,

* Bitbucket,

* Github

* elsewhere ?

0 vote
Nick Pellow Atlassian Team Apr 09, 2014

If you are using Stash, the upcoming release of FishEye (3.4) will make the following process a single-click operation once you have an Application Link established between FishEye and Stash.

However, until then - you must:

* In FishEye

** when adding a new Git repository select: "Generate key/pair for SSH"

** Generate

** Copy the public key shown to your clipboard

* In Stash

** Go to: Manage account

** SSH Keys

** Add Key

** Paste in the key you just copied and save.

Then go back to FishEye and hit "Test connection".

Now, fisheye will be able to fetch and clone the repository in Stash via SSH and their will be no need for you to embedd any passwords in the URL.

Suggest an answer

Log in or Join to answer
Community showcase
Bridget Sauer
Published Mar 09, 2018 in Jira Service Desk

E.L. Fridge's take on education, Jira Service Desk, and creative Jira use cases

...word of mouth, so by 2016, we were working with several other entities on campus to implement Jira Service Desk . The Atlassian motto of “for every team” has really come true for us in this case. We...

360 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot