Atlassian Connector not working properly in IntelliJ IDEA

I have installed the Atlassian Connector for IntelliJ IDEA in my IDEA Ultimate 13.1.6. Jumping from Fisheye to IDEA works as intended. However, that unfortunately that is about the only thing that works sad

I have configured the connection in my project and when I test the connection it says "Connected Successfully". I've also set the "Crucible Server Contains Fisheye Instance" flag. However, when I try to configure FishEye in the "Defaults" tab, I can select the FishEye server but the "Default Repository" stays empty ("None"). 

The context menu item as described in https://confluence.atlassian.com/display/IDEPLUGIN/Using+FishEye+in+the+IntelliJ+Connector also is missing.

Regarding the Crucible part, when I try to create a review, I can see the repository as described in https://confluence.atlassian.com/display/IDEPLUGIN/Creating+Crucible+Reviews+in+IDEA

After clicking on "Create review..." I get an exception 

com.atlassian.theplugin.commons.remoteapi.RemoteApiException: Server returned HTTP 400 (Bad Request)
Reason: IllegalArgument
Message: CreateReview requires at least one ReviewData or DetailedReviewData element

 

I also see some output in the shell I've started IDEA in. There are many lines like this

isFishEyeConfigured == false

ahd also

WARN - mons.httpclient.HttpMethodBase - Going to buffer response body of large or unknown size. Using getResponseBodyAsStream instead is recommended.

when I'm trying to use the plugin's features.

 

Any hints on how to debug this?

3 answers

1 accepted

Hello Steffen,
pre-commit reviews are currently broken in the stable version of the connector. This has been fixed, and should work as intended in the next release; if you're feeling adventurous, you can try using unstable snapshot builds (available in the connector's global configuration, under General/Auto Upgrade) where this should already be working.
I can't reproduce the Fisheye issue using FishEye 3.7.0 - the "Default Repository" combo box refreshes properly after setting the default server. Which FishEye version are you using?

I was able to get the link from IDEA to Fisheye to work by adding 

<default-fisheye-repo>myRepoName</default-fisheye-repo>

manually to the atlassian-ide-plugin.xml

Hi Karol,

I managed to get it to work. It did however need a lot of manual fixing to get there. I think I'll wait until the final release of 3.0.15 before investigating further.

Thanks so far!

Regards
  Steffen 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Marketplace Apps

Tips on how to choose the best estimation method for your planning

Planning and grooming sessions all come with their own sets of rules. Team members meet to estimate stories or other work items, all according to an agreed-upon process. And with every session comes ...

65 views 0 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you