Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,374
Community Members
 
Community Events
176
Community Groups

Why does google hate answers.atlassian.com?

JamieA Rising Star Sep 29, 2011

In order for this not to become just a bad version of the old forum we need to be able to refer to previous answers. However I cannot find any of my previous answers.

Just now I was looking for this, so asked google for "site:answers.atlassian.com GenericValue", but it didn't turn up. This is just an example, all I ever seem to get from google is the tags page or some other aggregate page.

7 answers

1 accepted

0 votes
Answer accepted

We figured it out. It's a problem in robots.txt that's got a nofollow meta tag. I'll just want to prepare for the inundation of spam before introducing this fix, and I'll update both ANSWERS-254 and this page when it's fixed.

Oh, and by the way, copying and pasting doesn't work well in the editor! That's why the above snippet appears in a white box.

An update on this issue. Given that we'd really like to address the spam issue before fixing the indexing problem, we're targeting a couple weeks for a release that encompasses both.

Another update. We've fixed this now. So far, it looks like Google's returning results a bit better.

0 votes
JamieA Rising Star Oct 02, 2011

Perhaps any user's first one or two questions/comments/answers have to be approved by a moderator, after that they're free. No self-respecting spammer would bother to come up with a valid question.

0 votes

By the way, there is a benefit to the fact that we're not indexing properly on Google. Once we fix this, Answers will become much more appealing to spammers. I'd like to try to solve both issues at once, but spam mitigation is challenging. Akismet had a bunch of false positives, so I'd like to create rules in the system to prevent spamming. I'm open to any ideas!

0 votes

We're hopefully going to tackle that as well. See ANSWERS-87.

0 votes

It's a bit of a struggle within Answers too - if you've a one-word search, I think it's fine - it checks labels and then body text, but multiple word searches all seem to do OR, whether I put quotes round a phrase, state AND, use && etc. Pretty painful when you want Jira && permission && reporter for example. That should be a handful of results, not 46 pages of 50 answers a page.

0 votes

We know about this problem and just got our SEO team on top of it. I'll update this post when we have a status update.

0 votes
Eva Rising Star Sep 29, 2011

I found it much easier to just search the old forum itself. I think a lot of questions had already been answer in the old forum and yet you cant search the old questoins here nor google. I wish Atlassian move the old questions/answers here than for users to go both places ...

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events