Editor bugs and broken @mentions Edited

Tyler Tadej Atlassian Team Sep 18, 2017

Hi folks,

On the morning September 8th we worked with our vendor and deployed a change to this site that we hoped would fix some of the 'flagged as spam' issues many of your were experiencing. Unfortunately, our efforts did not adequately fix things as intended and created some new bugs.

Current issues are as follows:

  1. Posts with @mentions will get rejected
  2. Adding an image and then typing more content will duplicate the image and your typed content will disappear
  3. Other types of pasted content is rejected
  4. Headings are missing in the format dropdown for those that have the permissions to create articles

Here is what is being done:

  • @mentions have been disabled until the issue is resolved
  • A current workaround for #2 is to hit return/enter twice, then go back to the top line to insert an image.
  • The dev team has a fix that addresses issues 1#, #2, and #4 that we are planning to release later today
  • We will spend more time addressing #3 as there are a few edge-cases with pasted content that we need to spend more time testing. Ideally, all users will be able to write, and copy/paste anything from other websites and not have to worry about a post getting rejected due to some odd HTML markup that the backend system doesn't like.

We'll continue to post updates here. Thanks for your patience. And to those that I was able to meet at Summit - thank you for showing me some of these issues in person. We're excited to get our editor in better shape and build cool new features for you!

2 comments

Boris Berenberg Community Champion Sep 18, 2017

Thanks for being so transparent with this.

Tyler Tadej Atlassian Team Sep 18, 2017

Update

We've deployed a fix that should address the following issues:

  • @mentions now work. I'll let @Jack Brickey chime in here to verify (fingerscrossed)
  • Images can be added to posts without weird things happening when you type out more content

thumbs-up.jpeg

  • Headings have been added back to the Create Article editor
  • Pasting content from external sites should be less painful, though it is not perfect yet.. read on

Remaining known issues

  • Posting an image-only in a reply (no text or other content) does not work in Discussions. This is a known bug with the platform.
  • Sometimes copy/pasting content will copy data-* attributes which will get rejected. We're working on a fix for this
  • There are other types of HTML elements that might slip through the editor paste sanitization; we'll be capturing error logs over the coming days to address these edge cases.
  • Separate from spam filters, there are frustrations with the height of the editor when typing long replies (like this one!).

Thanks for your patience. If you still experience issues, please report them on this thread or to the related Jira issues. We'll keep them open:

https://jira.atlassian.com/browse/COMMUNITY-59

https://jira.atlassian.com/browse/COMMUNITY-96

Thanks, Tyler! 

Comment

Log in or Sign up to comment
Community showcase
Published Aug 10, 2018 in Feedback & Announcements

August 2018 Community Awards

I'm so excited that it's time for another round of Community Content Awards! I really love the opportunity to recognize some of the awesome Community Champions and community members who are...

1,030 views 28 27
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you