Plugin SDK and Confluence.war: Spring version mismatch

An atlas-created Confluence plugin for version 5.10.8 of Confluence has dependencies for Spring that are very much earlier than the actual install-provided versions.  For example, only version 2.0.8 of spring-context.jar is pulled-in as a maven build dependency, but the version used in the confluence.war as well as our running production instance uses version 4.2.5... that's two major versions difference! 

 

Is there a reason of such a difference?  Can I safely specifiy the current 4.2.5 versions in my plugin project's POM?

0 comments

Comment

Log in or Join to comment
Community showcase
Ignacio Pulgar
Posted yesterday in Off-topic

Friday Fun: What's your favorite quote?

Hi all! You've probably heard a lot of famous quotes: smart, hilarious, inspiring ones... Maybe some of them kind-of related to an Atlassian product? I really love those pieces of wisdom concentrat...

45 views 4 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot