Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Installation instructions.

SteveT July 1, 2019

I have a complaint.

All of the installation Instructions for Jira, Jira Software and Jira Help Desk all state "download the installer for your  Operating System".  Which is extremely misleading to me.

I downloaded all 3, Jira Core, Jira Software and Jira Help Desk and successfully installed Jira Core on my OS (Centos 7).

I then followed the instructions (located at:

and tried to install Jira Software and noticed that it also wanted to install a Tom Cat Server (Catalina).  When I re-reviewed the installations documents,  It did not mention anything other than "install the server".  So I tried to install the server as how I initially set up Jira Core and Confluence.  It blew up big time because it did not like the installation folder already had a copy of it installed.  huh ?  I followed your instructions.

Confused, I went through all of the online documentation and nothing mentioned "install Jira Core, then download the Apps".  I finally found the correct information in the Community section on the Website..


So I uninstalled everything Jira and then reinstalled "Jira Core".  Went into the Administrators, Applications and on the right it stated "try Jira Software and Try Jira Service Desk", of which I already have licenses for.  After spending hours trying to get Jira to install, the final installation took less than 30 minutes of Core, Software and Service Desk.

Also, a very confusing part is about the JIRA_HOME environment variable.  In one document, it is stated (for manual installation?) to set the JIRA_HOME variable manually.

This is not accurate either.  It seems that if this is set, Jira Core may throw exceptions and break the installation into multiple folders within the JIRA_HOME folder.  

Example: /opt/atlassian/Jira  and /opt/atlassian/jira-7.12.3 and /opt/atlassian/jira-data.  

I was trying to install Jira Core 8.2.2, so where the hell did it get 7.12.3 from ? It is NOT installed nor had any environment variables, configurations set, etc for 7.12.3 ???

The JIRA_HOME variable was set to /opt/atlassian

Very confusing.

When I finally uninstalled everything jira, I also removed the JIRA_HOME environment variable.  It seems that Jira Core on an installation dislikes this being set.


Oh, I also tried the Manual Installation.  everything went VERY smoothly, but Jira Core refused to start stating something about the JVM being the wrong one ?  When I uninstalled everything, the .bin file installed and ran with no issues.  Strange.


I would suggest that someone please review the installation instructions and update these to NOT try and install the 3 installers, but Core first followed by downloading the Apps from within the Administration section of Jira, within Jira Core.


I would also look into correcting the instructions that through the Installer itself (.bin files) that the JIRA_HOME variable is NOT set at all.


Thank you.  and thanks also to whomever you were that ran into the same issues or similar issues and posted a Community post about the correct order and way to do this.  It should be in the installation guides for new installers.



1 comment

Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
July 2, 2019

Hi @SteveT and welcome!

I'm sorry your initial go was a bit rough and congratulations for sticking it out to the end.  I have added the "atlassian-support" tag to your post ti bring this to the attention of Atlassian staff.  I'll also thank you on their behalf for the details in your post as those always help.

I agree that the install documents could do a better job of helping a new admin understand the nuances of a multi-product install so the process makes more sense and goes smoother.  I'll be watching this tread to see what happens.


SteveT July 2, 2019

Thank you for your feedback.  I've been using both Jira and Confluence for a few years now.  I like both so much , I decided to buy it for my own Business/Lab. More so to get more in-depth with these products.


Confluence (I know, wrong community ;)  ) installed manually from the .tar file and it installed with no issues. Outside of the "no MySQL" driver, which was easily remedied. Again on CENTOS 7.  I installed it on a box I had laying around that really was not up to specs, but it n ran great albeit a little slow.  Bought a 1U 12 core server, 32gb RAM dedicated server and swapped HDs.  Slight issue with Centos, but overcame that in a few minutes.  Needed to rebuild the caching on Centos.  Once that cleared up, Confluence started and ran FAST !  

Being that I and or 1 other person will be using it here, no need for anything beefier.


Yes, both Confluence AND Jira (Core,software,ServiceDesk) are running on the 1 system.  Had 1 issue with the JVM Memory was over 75% maxed out on Jira.  Changed the System Variable for the JVM and it screams now.  Utilization is back down below 25%.


I do have an issue with Confluence, but I have not researched this yet.  You can make links to web pages or point to Confluence pages (redundant linking), but you can not point to and link to any files local on a Shared Drive.  Like I said, I want to research this more.


I'll have other comments to share and will chime in to answer others as needed/possible.


Thank you again for your response.





The label of "I'm new here" is a misnomer.  I've been using both Confluence and Jira for years now so I guess that makes me not a newbie ?




Log in or Sign up to comment
AUG Leaders

Atlassian Community Events