Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I am upgrading to Crowd 3.1.1 from Crowd 3.0.1 and am now unable to log in

After starting Crowd I am unable to log in to Crowd. The log in screen appears but my credential return Invalid login.

I have SSO set up with my other Atlassian applications. I am still able to log in to the other applications and can then navigate back to Crowd and am automatically logged in so my credentials are still working, I just cant log directly in to Crowd any longer.

As a side note, While tailing the catalina.out on my Ubuntu server (in my virtual lab with no internet access) I notice that Crowd is trying to connect to btf-analytics.s3.amazonaws.com and is failing due to UnknownHostException which would be normal since there is no internet access for this test environment. Why is Crowd trying to connect to anything as this should not be the case and gives me security concerns?

1 answer

1 accepted

0 votes
Answer accepted
Marcin Kempa Atlassian Team Dec 21, 2017

Hi @Lance Stratton,

Thanks for posting this question! Could you tell me more about your directory configuration? I mean where do users for Crowd application come from? do you have internal directory mapped to Crowd application? In other words, were admins for Crowd (including your account) stored in the internal directory (local database) or do they come from remote directory?

Regarding the connection to analytics.s3.amazonaws.com, this is how Crowd sends some analytics events that helps us to understand how customers use our products. You may learn more about data we collect here https://www.atlassian.com/legal/privacy-policy (this is for all of Atlassian products).

If you are concerned about the security, you may disable sending out the analytics data. This may be done in Crowd general configuration UI.

 

Best Regards,

Marcin Kempa

There is an internal Employee directory in Crowd where we add users. I figured I would try to disable the analytics for Crowd just so that it wouldn't write errors to the logs when starting. This doesnt seem to work for me. When I navigate to the Analytics in Crowd settings I get a little box that pops up and says ! NPS configuration could not be retrieved, check your connection with the server. If I select Disalbed and then try to save I get another box that pops up and says ! Configuration could not be saved, check your connection with the server

Not sure what the problem is there since the web interface is accessible from the workstation that I am connecting from and I can ssh to the server but obviously there is a disconnect somewhere.

Interestingly enough, I read this page

https://confluence.atlassian.com/kb/disabling-analytics-throws-configuration-change-could-not-be-saved-check-your-connection-with-the-server-816681579.html

I was using Chrome (60.0.3112.113 64-bit), I tried opening an incognito window and performed the same steps but was both unable to log in or save that Analytics setting.

I then decided to try another browser all together. I opened Firefox (54.0.1 32-bit) and was able to log on to crowd without having to resort to the SSO workaround. I was also able to save the Analytics setting with no pop up dialogs except ! Configuration change saved successfully.

Marcin Kempa Atlassian Team Dec 21, 2017

So to summarize what we know so far, while using other browsers you are able to login to Crowd console, but not with Chrome even in incognito mode.

Do you have any other Crowd instance like a test one that might be running in similar or in sub domain?

Can you check your SSO cookie name in the Crowd's general config, and then verify if in Chrome Developer tools if you do not have more than one such cookie set for Crowd domain?

 

Regards,

Marcin Kempa

I'm not sure why, but today I attempted to reinstall Chrome in my offline virtual lab to see if the offline installer would update to the newest version Chrome. The install failed for whatever reason, but afterward I Open Chrome again and tried to log in and it now works as it should. I was able to log in and I no longer receive the error I was receiving about connectivity problems with the server.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence Cloud

Share your Confluence Cloud experience for a chance to win $500!

Take our 5-minute survey to win a $500 Visa gift card! Are you currently using Confluence Cloud? We want to hear from you! Fill out this quick survey about your Confluence Cloud experience so we ...

139 views 1 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you