Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Crowd Installation on Windows 10 Pro x64

Hi, I went through the Getting Started installation guide at https://confluence.atlassian.com/crowd/installing-crowd-and-crowdid-191862.html and I'm stuck with this:

C:\Crowd>start_crowd.bat

To run Crowd in the foreground, start the server with start_crowd.bat /fg

The JRE_HOME environment variable is not defined correctly
This environment variable is needed to run this program

I have Java SE Development Kit 8 Update 172 (64-bit) no JRE.

My {CROWD_INSTALL} is at C:\Crowd
My Crowd Home is at C:\Crowd_data
My crowd-init.properties setting is crowd.home=c:/Crowd_data

I've also renamed the files to the 64bit files.

temp.png

Here's my Environment variables looks like:

temp.png

I tried everything from here, adding JRE_HOME, in Path variable that are suggested in the community forum and all still no luck.

and when I tried to start the bat file under step

4. Start Crowd and Complete the Setup Wizard

it throws the error above.

 

Hope someone can shed some light.

 

 

 

1 answer

1 accepted

0 votes
Answer accepted
AhmadDanial Atlassian Team Jun 28, 2018

Hi, Neil.

With reference to a question that was asked before - Crowd is not starting, let us look at the answer provided by Ann Worley which refers to the requirement of Crowd:

the JAVA_HOME variable has to point to a full JDK, we shouldn't be using JRE_HOME:

It is not enough to have the JRE only. Please ensure that you have the full JDK. You can download the Java SE Development Kit (JDK) from the Oracle website.
Once the JDK is installed, you will need to set the JAVA_HOME environment variable, pointing to the root directory of the JDK. Some JDK installers set this automatically (check by typing 'echo %JAVA_HOME%' in a DOS prompt, or 'echo $JAVA_HOME' in a shell). If it is not set, please see Setting JAVA_HOME.

Can you please give this a try and let me know if it works for you?

Hi @AhmadDanial, thank you. I've fixed the issue already by removing the /bin in the path.

AhmadDanial Atlassian Team Jun 30, 2018

Hi, Neil.

Excellent. Please let me know if you have any other concerns and I will be happy to help. Else, please accept the answer provided as the solution. Thanks.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

306 views 9 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you