"View" and "Edit in Office" for Office documents launches application but file doesn't open

When I use the "View" or "Edit in Office" links for Office documents, the application will launch but the file doesn't open - in other words, I get a new, blank file in the application. I think this is related to this problem (https://confluence.atlassian.com/display/CONFKB/Edit+in+Office+Opens+Blank+in+Office+2010), but since I'm using a different technology stack, I'm unsure of the workaround. Here's what I have:

Confluence 4.3.7
Office Connector 2.1.10
Mac OSX 10.8.4
Firefox 24
WebDAV Launcher 1.0.7
Office 2011

I've gone through all the configuration steps for the WebDAV launcher and Office connector. Since the applications launch correctly, I'm assuming that the problem is elsewhere.

4 answers

1 accepted

Per this support thread, the bug linked from within, I seem to have come across a known issue:

https://support.atlassian.com/browse/CSP-111004

Ann Worley Atlassian Team Jul 30, 2014

Phil, the public cannot access the support thread. :)

Do you have any plugins enabled in Firefox? Ad-block plus or noscript can break things frequently.

Aside from Firebug, the WebDAV Launcher is the only other Add-On I've added to Firefox.

So that is odd. My guess is that you are still being bit by the bug. Have you tried the work around? My thought is that Office 2011 isn't that different then Office 2010. 2010 and 2013 were major releases.

0 vote
Ann Worley Atlassian Team Oct 09, 2013

Per this knowledegebase article it is necessary to use OpenOffice with the Office Connector on the Mac platform:

https://confluence.atlassian.com/display/DOC/Office+Connector+Prerequisites

I discovered a somewhat similar issue with the Office Connector that may or may not be related, but I wanted to share it in case anyone else runs into it.

I attached an .xls file to a page titled "Module 4: Working With Macros". I inserted the Office Excel macro and found that the File Name drop-down was empty and didn't let me choose the file I had attached. Usually, it is prepulated with any of the available approporiate attachments; and if there no appropriate attachments, it displays a message saying so. The problem, it turned out, was the colon (:) in the page title. I edited to "Module 4 Working With Macros" (with no colon) and the Excel Macro worked as expected. The same issue occured with all of the Office Connector macros (i.e., Word, PPT, PDF).

Ann Worley Atlassian Team Jul 30, 2014

Ryan, we have a bug report open to resolve this:

https://jira.atlassian.com/browse/CONF-24540

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,788 views 26 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you