"Unknown Attachment" displaying for Anonymous users instead of image

Hi, I've enabled Anon access, and selected "view user profiles". However, when selecting some pages as a Anon user, I cannot see the attachements/links. In others I can. I have a one space where the results are mixed, I can see attachement/Links images on some pages, others I cannot.

Some attachements are .PNG others .GIF

Any ideas?

Confluence 5.2.3 build 4394

2 answers

1 accepted

0 votes
Accepted answer

Hi Phil,


I believe some of the attachment is attached to pages which are restrict annoymous user.

For example, attachment A is attached in page 1 and page 1 is restricted. In page 2, there is a attachment link which refer to the attachment A in page 1. When a user who does not have view permission in page 1 view the attachment in page 2, the attachment will not render.

Regards,

Jing Hwa

Thanks. I thought I had checked the page restrictions, obviously not. All sorted now.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published yesterday in Confluence Cloud

Happy holidays from our team to yours!

Hi Community!  2018 was filled with changes for our team, both big and small, and we've taken a lot of time to both celebrate our wins and recognize areas of improvement. One thing that we're a...

104 views 1 14
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you