"Unknown Attachment" displaying for Anonymous users instead of image

Hi, I've enabled Anon access, and selected "view user profiles". However, when selecting some pages as a Anon user, I cannot see the attachements/links. In others I can. I have a one space where the results are mixed, I can see attachement/Links images on some pages, others I cannot.

Some attachements are .PNG others .GIF

Any ideas?

Confluence 5.2.3 build 4394

2 answers

1 accepted

This widget could not be displayed.

Hi Phil,


I believe some of the attachment is attached to pages which are restrict annoymous user.

For example, attachment A is attached in page 1 and page 1 is restricted. In page 2, there is a attachment link which refer to the attachment A in page 1. When a user who does not have view permission in page 1 view the attachment in page 2, the attachment will not render.

Regards,

Jing Hwa

This widget could not be displayed.

Thanks. I thought I had checked the page restrictions, obviously not. All sorted now.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

554 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you