installing Confluence 5.1 on Mac OS 10.8.3

I installed Confluence 5.1-OD-13 on Mac OS 10.8.3 following the instructions here:

https://confluence.atlassian.com/display/CONF35/Installing+Confluence+Standalone+on+Mac+OS+X+from+Zip+File

Confluence seems to be running but http://localhost:8080 is 404.

sudo lsof -i :8080 shows nothing, sudo lsof -i -nP | grep "8080 (LISTEN)" shows nothing.

localhost is active, I tested that using Apache.

8 answers

1 accepted

This widget could not be displayed.

Sounds like Confluence did not start up successfully. Do you see any errors in Confluence logs (CONFLUENCE_HOME/logs/atlassian-confluence.log)?

Jun 25, 2013 2:45:45 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server} Setting property 'debug' to '0' did not find a matching property.
Jun 25, 2013 2:45:45 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine} Setting property 'debug' to '0' did not find a matching property.
Jun 25, 2013 2:45:45 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'debug' to '0' did not find a matching property.
Jun 25, 2013 2:45:45 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'debug' to '0' did not find a matching property.
Jun 25, 2013 2:45:45 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8090
Jun 25, 2013 2:45:45 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 251 ms
Jun 25, 2013 2:45:45 PM org.apache.catalina.core.StandardService start
INFO: Starting service Tomcat-Standalone
Jun 25, 2013 2:45:45 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.35
2013-06-25 14:45:46,255 INFO [main] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 5.1-OD-13 [build 4332 based on commit hash d19eb0a3bfb8be622c0ab1a0b04bdc0ee8273a95]
Jun 25, 2013 2:45:51 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8090
Jun 25, 2013 2:45:51 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 6529 ms

Try localhost:8090

This widget could not be displayed.

Aack, dyslexia strikes again. Thanks.

This widget could not be displayed.
David Simpson Community Champion Jun 25, 2013

Using Confluence 5.1-OD-13 suggests that you're running the OnDemand version for Confluence rather than the normal version. Is this on purpose or by pure chance that you've installed the wrong version?

OD == OnDemand -- cryptic, right?

This widget could not be displayed.

That's on purpose, I plan to export from an OnDemand instance, import into the installed version, do some tasks that require add-ons, export, and import back into OnDemand.

This widget could not be displayed.

With Confluence 5.3.1, under MacOSX 10.9, the system doesn't want the .command file to play. It says something like : "impossible to open "OS X - Run Confluence In Background.command" because this app comes from an unidentified developper"... :'(

This widget could not be displayed.

Hello Nicolas,

You can override this behavior by going to (Apple icon -> System Preferences -> Security & Privacy), click on Open Anyway where it says "OS X - Run Confluence In Background.command" was blocked.

Then change "Allow apps downloaded from:" to "Anywhere", and try to start confluence again, if everything goes ok, switch back this setting to it's previous value, for security reasons.

Regards

This widget could not be displayed.

Ok I've moved the entire home in my user's hierarchy, modified /Users/myuser/confluence/confluence/WEB-INF/classes/confluence-init.properties and everything works fine now.

Thanks for your help,

Nicolas

This widget could not be displayed.

Thanks Felipe, it worked fine ! Now I'm stuck with a "The license you entered was not valid." in the Confluence setup wizard... (as described here : https://confluence.atlassian.com/display/CONFKB/The+License+You+Entered+Was+Not+Valid)...

I've tried to check the permissions but doesn't work.

Regards,

Nicolas

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

466 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you