i18ntranslate=off does not (fully) work

Hi.

I've do, some time ago, a translation check using the "i18ntranslate=on" parameter. Then after using "i18ntranslate=off" the UI is messed up.

Some labels are shown again with the i18n label, like "sidebar.header.spaces.link" or "like.bethefirst" in the bottom of the page.

How I can remove completely the i18n labels from my user profile?

2 answers

0 vote

Hi Emanuele,

Can you let us know what version of Confluence you're using to replicate the issue, and if you have any screenshots you can send that show the behavior, it will also help.

Thank you!

Kind Regards,
Shannon

Confluence 6.4.0

 

Schermata 2017-10-27 alle 13.36.02.pngSchermata 2017-10-27 alle 13.30.14 (2).png

Hi Emanuele,

I just tested this, and I did run into a similar issue. All the labels disappeared except the sidebar.header.spaces.link and the ones on the UPM (Plugin Manager).

But then, for some reason, once I noticed I had a UPM update and then refreshed Confluence as it requested at the end of that, the labels went away.

Do you currently have an updates you can try in UPM or perhaps flushing the cache in Confluence? Does it make a difference if you add the i18ntranslate=off to the end of the primary URL or the current page you are on?

Kind Regards,
Shannon

Emanuele-

Apologies! I was able to replicate it again, and now it's stuck, and none of the above works this time.

I'm looking to see now if I can report this as a bug and also how we can turn off the labels now.

I will let you know what I find out.

Kind Regards,
Shannon

0 vote

Hi Emanuele,

I have created a bug ticket here:

I am still working on a solution for you as a workaround, so please stay tuned.

Kind Regards,
Shannon

Hello.
Thanks for information.

I have same problem with JIRA & Service Desk when using ?i18ntranslate=off it won't turn off.

Waiting for fix. Thanks

Maris,

Thank you for letting us know. This is for Confluence specifically but I'd like you to try this anyway:

  1. Stop Jira/Jira Service Desk
  2. Remove these two folders:
    1. JIRA_HOME/plugins/.bundled-plugins
    2. JIRA_HOME/plugins/.osgi-plugins
  3. Start Jira

Then, can you tell me if you still have the issue?

Kind Regards,
Shannon

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,920 views 27 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you