confluence not allowing page edits

I have confluence running in a docker container and have only a few ports open.

I can see the page (i'm logged in as admin) but then when I edit the page do I need to open up more ports in my firewall? if which ones.confluence not editing.PNG

3 answers

I have just found this and working my way through it, i will let you know what fixed it for me!

https://confluence.atlassian.com/confkb/unable-to-edit-any-pages-in-confluence-6-x-due-to-collaborative-editing-867362716.html

Thank you, Reg!

The error you saw can be caused by a lot of things, and looking in the logs should ultimately help you narrow down the issue.

If that article above doesn't fix your issue, you can have a look here:

Be advised that Synchrony runs on port 8091 by default.

Once you solve your issue you can let me know and I'll accept your answer as resolved. :) 

Regards,

Shannon

I have just switched the collaboration feature off for now

Alright, Reg!

If you troubleshoot later do let me know if you run into any issues or have a question.

Regards,

Shannon

currently I have confluence running in a docker container and it is using a local host but I have confluence running on 172.28.1.4 is there a way to change the ip address synchrony works on

Hi Reg,

It appears you may be able to modify it using a System Property:

Perhaps this one: 

synchrony.host
6.0.4 127.0.0.1   This is the IP that Confluence uses to connect to Synchrony. It defaults to localhost. Change this if you need to allow Confluence to contact Synchrony via a custom hostname or IP address.

See Change your Synchrony Configuration for further details.

I haven't personally experienced changing this myself but it should help you to get started there.

Regards,

Shannon

i have the same problems. Only cancelling the Synchrony funftion, makes it possible to edit a page. In the same constellatoin it works for about 6 weeks. but from one day to another it wont works any longer.
Windows updates responsible? Port and everathing else hadn´t been changed.

Have you worked through the troubleshooting doc mentioned?

I run the same issue today.

Confluence 6.5.0 - Standalone


After some digging I found old file synchrony.pid was never refresh on restart

Stopping confluence service and deleting old confluence/temp/synchrony.pid did the trick

Then I started service again, file synchrony.pid was newly generated and Collaborative Editing works

i don´t find this File

Confluence Server 6.6.2

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,544 views 4 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you