chart plugin update to 2.0.4 fails

I am trying to update the Chart Plugin from 2.0.2 via the add on manager. The update fails with "An unexpected error occurred. Refer to the logs for more information."

The logs in /opt/atlassian/confluence/logs/ contain no further information.

2 answers

I had this issue - found it was due to the mysql max_allowed_packet was being exceeded. Changed [mysqld] section of my.conf to have

max_allowed_packet=16M

fixed problem.

Thanks for posting!! this was exactly my problem.

Can you find atlassian-confluence.log in the Confluence home directory? Confluence Home directory is defined in <Confluence install folder>/confluence/WEB-INF/classes/confluence-init.properties file.

Did you encounter the same issue trying to install/update other plugins via the manager? How about manually download the plugin jar from https://marketplace.atlassian.com/plugins/confluence.extra.chart and manually upload it from the manager via "Upload add-on", will it works?

Also, ensure that the url you use to access Confluence via the browser matches the url configured in Confluence Admin > General Configuration > Base URL. This url mismatched could cause a failed plugin installation/update too.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

919 views 13 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you