Why don't Image links and external links that contain an asterisk work?

When I add an external image with a URL that contains an asterisk, it works in the image preview, but when I save, or do a page preview, it's a broken link. When I use the same URL as a link, the link is created, it's blue, it's underlined, but it's not clickable... If I replace the askterisk with %2a both cases work. (Links to Graphite graphs (http://graphite.wikidot.com/) often contain asterisks... so this is annoying.

2 answers

Hello phrend,

I had a similar support case to yours. A user was trying to use Confluence as a dashboard. Their metrics were coming from graphite. We saw that the image preview worked, but when the link was added to the page the graph did not render.

I created the following issue for their problem.

https://jira.atlassian.com/browse/CONF-26758

The extra bit of info around the asterix not being able to render is very useful. Please feel free to visit that issue and add your comments. I have attached this post to the ticket to further increase it's visibility.

Thanks - will do! :)

The problem your other customer was having is EXACTLY the problem that I'm seeing - I'm using Confluence 4.3.2

Here's a simple script I wrote to help me work around the issue:

#!/bin/bash

#
# confluence doesn't like asterisks in URLs, so this script converts them to %2a
#

if [ $# -ne 1 ]; then
  echo "Usage: $(basename $0) '<url>'"
  exit 1
fi
echo ""
echo "URL for Confluence:"
echo $1 | sed 's/\*/%2a/g'

I tried to open a support ticket yesterday, and was getting an error... I just clicked on your JIRA link above, and get taken to a similar page... the text is something like, "Have you ever been to support before..." and there are two buttons - they are more verbose, but basically are, "No - set my account up" and "Yes" - when I click the, "No - set my account up" link, I get the following error (as I did yesterday):

414 Request-URI Too Large

The URL of that error page is below - so you can see why it's "too large":

https://id.atlassian.com/profile/linkAccount.action?application=jac&continue=https%3a%2f%2fjira%2eatlassian%2ecom%2fbrowse%2fCONF-26758%3fapplication%3djac%26continue%3dhttps%253A%252F%252Fjira%2eatlassian%2ecom%252Fbrowse%252FCONF-26758%26application%3djac%26continue%3dhttps%253A%252F%252Fjira%2eatlassian%2ecom%252Fbrowse%252FCONF-26758%253Fapplication%253Djac%2526continue%253Dhttps%25253A%25252F%25252Fjira%2eatlassian%2ecom%25252Fbrowse%25252FCONF-26758%26application%3djac%26continue%3dhttps%2...(IT GOES ON AND ON past the max chars allowed in a post)

phrend,

That is a very strange error to get. Could you try opening another support case today? What email are you using to try to signup? You can email me at dborcherding@atlassian if you don't want this discussion on our public forum.

I was able to get past it by going to either https://jira.atlassian.com/ or https://id.atlassian.com (can't remember which?) and logging in - not sure why it was creating a "forever looping URL" but it seemed to have something to do with trying to link my account on https://answers.atlassian.com to https://jira.atlassian.com/ - now that that's done, it seems to work fine.

I was able to add some additional notes to the ticket you mentioned above.

Thanks!

You may want to log a support ticket, as this sounds like a bug.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

902 views 23 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you