Why am I unable to authenticate to my Jira-Server?

Hello,

 

I have an authentifiation Problem, when I'm connecting to JIRA from Confluence. I want to create an issue, but I am not able to see my JIRA-projects.

Both applications, jira and confluence, are connected. When I want to integrate the issue from Confluence I get this error:

 

2017-07-11 11:09:36,430 WARN [http-nio-127.0.0.1-8090-exec-6] [applinks.core.rest.PermissionResource] handle Authentication failed for application link JIRA (2bf2fba4-d2f0-3249-80ed-cf396c5163a1) jira. Response Vary=Accept, WWW-Authenticate=OAuth 

 

This is how I configured the proxy-settings in my server.xml

 

<Service name="Catalina">

<Connector port="8040"
address="127.0.0.1"
maxThreads="150"
minSpareThreads="25"
connectionTimeout="20000"

enableLookups="false"
maxHttpHeaderSize="8192"
protocol="HTTP/1.1"
useBodyEncodingForURI="true"
redirectPort="8443"
acceptCount="100"
disableUploadTimeout="true"
scheme="https"
proxyName="jira.mydomain.com"
proxyPort="443"
bindOnInit="false"/>

 

<Engine name="Catalina" defaultHost="localhost">
<Host name="localhost" appBase="webapps" unpackWARs="true" autoDeploy="true">

<Context path="" docBase="${catalina.home}/atlassian-jira" reloadable="false" useHttpOnly="true">


<!--
====================================================================================

Note, you no longer configure your database driver or connection parameters here.
These are configured through the UI during application setup.

====================================================================================
-->

<Resource name="UserTransaction" auth="Container" type="javax.transaction.UserTransaction"
factory="org.objectweb.jotm.UserTransactionFactory" jotm.timeout="60"/>
<Manager pathname=""/>
<JarScanner scanManifest="false"/>
</Context>

</Host>

 

<Valve className="org.apache.catalina.valves.AccessLogValve"
pattern="%a %{jira.request.id}r %{jira.request.username}r %t &quot;%m %U%q %H&quot; %s %b %D &quot;%{Referer}i&quot; &quot;%{User-Agent}i&quot; &quot;%{jira.request.assession.id}r&quot;"/>

</Engine>
</Service>

 

How can this problem be solved?

 

Thank you in forward,

 

Christian

1 answer

This widget could not be displayed.

Hi - it seems you are using https - have you imported the certificates to your JVMs keystores? And what is the application link diagnosis saying? Can you link to Confluence pages from JIRA? Can you ping JIRA from your Confluence server and vice versa?

Cheers

Christoph

HI Christoph,

 

thank you for your fast answer andsorry for the delay.

 

Yes Jira and Confluence are on the same server and are able to establish the connection. It was also possible to import all Jira-users to my confluence.

We think the problem is related to the jira-installation, which is maybe corrupt.

We will try to test the integration by installing a brand new Jira.

I will give you an update, when the problem persists.

 

Thanks again.

All the best,

 

Christian

Hi Christian, 

You're welcome, thanks for letting me know and good luck :) 

Cheers 

Christoph 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

361 views 2 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you