Why am I not able to install the Page Approval macro?

Every time I try to install the Page Approval macro, I receive an error message that states the following: 

An error occurred during installation. Refer to the logs for more information.

Naturally, I go check the logs and this is what it states (where xxxxx = our domain):

2015-07-21 16:41:42,393 ERROR [UpmAsynchronousTaskManager:thread-3] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements OBR resolver has 57 unsatisfied requirements for installing plugin.4839264016869724364.pageapproval-plugin-2.2.4.obr
-- url: /rest/plugins/1.0/ | referer: https://xxxxx.com/plugins/servlet/upm/marketplace/search?q=approval

2015-07-21 16:41:42,393 ERROR [UpmAsynchronousTaskManager:thread-3] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.apache.commons.logging)(version>=1.0.4)(!(version>=2.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://xxxxx.com/plugins/servlet/upm/marketplace/search?q=approval

2015-07-21 16:41:42,394 ERROR [UpmAsynchronousTaskManager:thread-3] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.factory.config)(version>=2.5.0)(!(version>=3.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://xxxxx.com/plugins/servlet/upm/marketplace/search?q=approval

2015-07-21 16:41:42,394 ERROR [UpmAsynchronousTaskManager:thread-3] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.context)(version>=1.2.0)(!(version>=2.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://xxxxx.com/plugins/servlet/upm/marketplace/search?q=approval

2015-07-21 16:41:42,394 ERROR [UpmAsynchronousTaskManager:thread-3] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.aop.support)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://xxxxx.com/plugins/servlet/upm/marketplace/search?q=approval

2015-07-21 16:41:42,394 ERROR [UpmAsynchronousTaskManager:thread-3] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.context.event)(version>=1.2.0)(!(version>=2.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://xxxxx.com/plugins/servlet/upm/marketplace/search?q=approval

I've Google'd this issue but to no avail. 

We are using Confluence 5.7.1. We were, however, able to install this on a replica of our site and it worked just fine. 

Thanks in advance. 

1 answer

It was not compatible with confluence 5.7 it is now with the release of the 2.2.5 version. Maby you should try again!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,443 views 3 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you