• Community
  • Products
  • Confluence
  • Questions
  • We would like tu use Confluence v5.5.3 and v5.5.6 with 256 bit SSL certificate. When try to connect to Confluence https://localhost:8443 with firefox we get the error message: Code ssl_error_no_cypher_overlap

We would like tu use Confluence v5.5.3 and v5.5.6 with 256 bit SSL certificate. When try to connect to Confluence https://localhost:8443 with firefox we get the error message: Code ssl_error_no_cypher_overlap

Hello

We would like tu use Confluence with 256 bit SSL certificate.
When try to connect to Confluence https://localhost:8443 with firefox we get this error message.

A secure connection failed

An error occurred during a connection to localhost: 8443. You can not communicate securely with peer: no common encryption algorithm. (Code ssl_error_no_cypher_overlap)

The page you are trying not shown because the authenticity of the received data could not be verified.
You may contact the operator of the site and notify of the problem.

Could you help me how can we use Confluence with 256 bit SSL certificate

Best regards
Ferenc Jordanics
mail: Jordanics.Ferenc@gmail.com

  
Affects Version/s5.5.3, 5.6.5
Customer TimezoneGMT+1
Phone Number+ 36 30 261 5378

2 answers

0 votes

The error you are seeing happens when the browser is unable to agree on a way of talking to the server.  Sometimes this is because people have turned off some levels of ssl support in the browser (often for security - it's usually the less secure protocols that they turn off), but sometimes it's genuinely because a server certificate does not support the methods the browser has.

To fix this, you'll need to 

  1.  Make sure Confluence is running over SSL.  This is not a function of Confluence directly, it's done by the container or web server if you're using one, but the basics are that you'll need a certificate (the 256 bit one you suggest) installed in the server.  See https://confluence.atlassian.com/display/DOC/Running+Confluence+Over+SSL+or+HTTPS
  2. You'll need the browser to support it

I actually suspect the problem is the browser support though.  256 bits is WAY too low and my guess is that your browser has rightly dropped support for it.  You should really be looking at 2048 bits as a minimum nowadays.

 

0 votes

Hi Alfa Beta, 

I answered a question related to this topic yesterday. You can check it on this link to see the Willian's suggestion as well. 

 

If the problem is related to Firefox, you can try the steps below:

Enable support for 40-bit RSA encryption in the Firefox Browser:
1: enter 'about:config' in Browser Address bar
2: find/select "security.ssl3.rsa_rc4_40_md5"
3: set boolean to TRUE

Once this is done, when the Welcome screen is manually refreshed, a screen requiring the user
to register the Certificate Exception will come up, where the Error message had been before. 
Once the Exception is registered, the Welcome screen, and other Report screens will display


Regards, 

Renato Rudnicki

Hi Alpha, Now I realize you opened the same question twice. Is there a reason for it?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

919 views 13 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you