View the forums in the frontend at Community Forums Addon generates error messages

Dear Support Team,

I have a problem with the addon Community Forums. When I'm logged in Confluence and as a guest would like to see the forums, there are a bunch of error messages.

These look for example like this:

Search error occurred
 
                                                                            {"status-code":500,"stack-trace":"java.lang.NullPointerException\n\tat
 
com.adaptavist.confluence.forums.service.search.results.impl.DefaultSearchResultsConverter.getViewedPages(DefaultSearchResultsConverter.java:220)\n\tat
 
com.adaptavist.confluence.forums.service.search.results.impl.DefaultSearchResultsConverter.topicResults(DefaultSearchResultsConverter.java:45)\n\tat
 
com.adaptavist.confluence.forums.service.search.impl.DefaultForumSearchManager.searchTopics(DefaultForumSearchManager.java:70)\n\tat
 
com.adaptavist.confluence.forums.controller.rest.ForumSearchResource.searchTopics(ForumSearchResource.java:59)\n\tat
 sun.reflect.GeneratedMethodAccessor4595.invoke(Unknown Source)\n\tat 
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)\n\tat
 java.lang.reflect.Method.invoke(Method.java:498)\n\tat



Can you maybe help me there?

This addon I have already bought and put it in a Confluence server.

Thanks in advance.

3 answers

1 accepted

1 vote
Accepted answer

Hi Alexander,

My name is Rafael Franco and I'm the Tech Lead of the Product Team here at Adaptavist. I'm sorry to hear you're having problems with Community Forums. Could you be so king to open a bug request in our support portal and we'll investigate?

http://productsupport.adaptavist.com/servicedesk/customer/portal/4

Thank you,

Rafael Franco

Hi Alexander,

We got it, thanks for that. I believe there's indeed a problem with anonymous access using Community Forums. We'll pick this for our next sprint. We'll keep you posted through our support portal.

Cheers,

Rafael

Hi Rafael,

Thank you for your very quick help and I have submitted the bug in the portal. I do not know why it came to the mistakes and know that your addon should work well.

Let's see, maybe I did something wrong during installation.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,523 views 25 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you