It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Upgrading confluence from 5.6.3 to latest

Hi can you give me the detailed steps on upgrading from 5.6.3 to latest version . I have tried upgrading directly and have resulted in errors with the database .  I had to move the database to a different instance as well. 

1) Upgraded using the upgrade existing server during installation option

2) Database upgration done using the steps defined in 

https://confluence.atlassian.com/doc/database-setup-for-mysql-128747.html

3) Dumped existing database and followed steps in 

https://confluence.atlassian.com/kb/how-to-fix-the-collation-and-character-set-of-a-mysql-database-744326173.html

 

But still Im getting the database error when starting up . 

https://confluence.atlassian.com/x/TABrFw

 

How can i resolve it is there any step i missed ?

Every time i switch a confluence server or database it has become headache

2 answers

1 accepted

1 vote
Answer accepted
Ann Worley Atlassian Team Aug 16, 2017

Hi Rajeev,

It looks like the upgrade didn't get started properly because of a licensing issue - this is from the log you linked:

2017-08-16 15:13:58,506 ERROR [localhost-startStop-2] [confluence.upgrade.impl.DefaultUpgradeManager] runUpgradePrerequisites Current license is not valid: SUPPORT_EXPIRED
2017-08-16 15:14:00,232 ERROR [localhost-startStop-2] [atlassian.confluence.plugin.PluginFrameworkContextListener] launchUpgrades 1 errors were encountered during upgrade:
2017-08-16 15:14:00,232 ERROR [localhost-startStop-2] [atlassian.confluence.plugin.PluginFrameworkContextListener] launchUpgrades 1: <p>Confluence support and upgrades for your current license have expired.</p><p>Please access <a href="http://my.atlassian.com">My Atlassian</a> as the license contact and purchase a license renewal for Confluence. If you have a new license, please enter it on this <a href="$CONTEXT/fixonly/fixlicense.action">page</a> and <b>restart</b>.</p><p>Alternatively, you can continue using Confluence by rolling back to a previous version. To do this you must perform a clean installation of Confluence of the version that needs to be restored then restore the confluence home directory to its pre-upgrade state. No database restorations need to be made.</p>

You may continue the upgrade by getting an evaluation license from https://my.atlassian.com and applying it before upgrading - eventually a new license will be needed, of course. Please see: What happens when the included maintenance ends?

SEN-2919943 

I have an active  license that expires on 12 Nov 2018 

Thanks for the tip; I have updated the license key again , then restarted the tomcat . then took a copy and  tried the updgrade and its working now . No idea why it has not taken the license before.

Ann Worley Atlassian Team Aug 17, 2017

It is music to my ears that it's working now! Thanks for following up.

1 vote

Hello Rajeev,

In migrating the database, did you follow the documentation on Migrating to Another Database? I'd recommend having a look at that to make sure there's nothing you didn't miss. 

If not, can you provide a few of the error lines from your startup messages so we can have a look?

Kind Regards,
Shannon

Hi Shannon,

Im moving it to another mysql instance itself , I have given the links in my question that specifies same.

I have gone through the steps of converting the collation and now i get a different error in webpage - no error in catalina.out.

here is . atlassian-confluence.log

 

 

 Cause

java.lang.reflect.UndeclaredThrowableException
    at com.sun.proxy.$Proxy97.permissionExists(Unknown Source)

caused by: java.lang.reflect.InvocationTargetException
    at sun.reflect.GeneratedMethodAccessor368.invoke(Unknown Source)

caused by: org.springframework.dao.InvalidDataAccessResourceUsageException: could not extract ResultSet; SQL [n/a]; nested exception is org.hibernate.exception.SQLGrammarException: could not extract ResultSet
    at org.springframework.orm.hibernate5.SessionFactoryUtils.convertHibernateAccessException(SessionFactoryUtils.java:224)

caused by: org.hibernate.exception.SQLGrammarException: could not extract ResultSet
    at org.hibernate.exception.internal.SQLExceptionTypeDelegate.convert(SQLExceptionTypeDelegate.java:63)

caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Unknown column 'spacepermi0_.PERMALLUSERSSUBJECT' in 'field list'
    at sun.reflect.GeneratedConstructorAccessor290.newInstance(Unknown Source)

Nic Brough Community Leader Aug 16, 2017

It looks like the tables in the new database are malformed.

I'd suggest following the migration instructions given by Shannon

I have followed the same instructions and the links were given in question let me try that same steps again and update you

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Confluence

Introducing Confluence Cloud and Jira Software Cloud Premium

Wherever you are in your team’s journey , our goal is to support your big ambitions. We’re a cloud-first company with the mission of unleashing the potential of every team, and to address the range ...

599 views 4 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you