Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,465,790
Community Members
 
Community Events
176
Community Groups

Upgrade issue (installer) 7.0.2 -> 7.12.2

We are trying to upgrade our Confluence v7.0.2 to the latest (v7.12.2 at the time of writing). When running the installer, the following error is produced:

In action "Update JVM Options when upgrading JDK 8 to JDK 11 [Run script]" (screen "Upgrade Actions [Form]"), property "Script":
java.lang.NullPointerException
at java.base/java.util.Objects.requireNonNull(Unknown Source)
at java.base/java.util.Arrays$ArrayList.<init>(Unknown Source)
at java.base/java.util.Arrays.asList(Unknown Source)
at com.install4j.script.I4jScript_Internal_257.eval(I4jScript_Internal_257.java:14)
at com.install4j.script.I4jScript_Internal_257.evaluate(I4jScript_Internal_257.java:*58)
at com.install4j.runtime.installer.helper.Script.evaluate(Script.java:33)
at com.install4j.runtime.installer.ContextImpl.runScript(ContextImpl.java:202)
at com.install4j.runtime.installer.ContextImpl.runScript(ContextImpl.java:196)
at com.install4j.runtime.beans.actions.control.RunScriptAction.execute(RunScriptAction.java:34)
at com.install4j.runtime.beans.actions.SystemInstallOrUninstallAction.install(SystemInstallOrUninstallAction.java:29)
at com.install4j.runtime.installer.ContextImpl$9.executeAction(ContextImpl.java:1731)
at com.install4j.runtime.installer.ContextImpl$9.fetchValue(ContextImpl.java:1722)
at com.install4j.runtime.installer.ContextImpl$9.fetchValue(ContextImpl.java:1719)
at com.install4j.runtime.installer.helper.comm.actions.FetchObjectAction.execute(FetchObjectAction.java:14)
at com.install4j.runtime.installer.helper.comm.HelperCommunication.executeActionDirect(HelperCommunication.java:271)
at com.install4j.runtime.installer.helper.comm.HelperCommunication.executeActionInt(HelperCommunication.java:256)
at com.install4j.runtime.installer.helper.comm.HelperCommunication.executeActionChecked(HelperCommunication.java:184)
at com.install4j.runtime.installer.helper.comm.HelperCommunication.fetchObjectChecked(HelperCommunication.java:167)
at com.install4j.runtime.installer.ContextImpl.performActionIntStatic(ContextImpl.java:1719)
at com.install4j.runtime.installer.InstallerContextImpl.performActionInt(InstallerContextImpl.java:159)
at com.install4j.runtime.installer.ContextImpl.performAction(ContextImpl.java:1147)
at com.install4j.runtime.installer.controller.Controller.executeAction(Controller.java:389)
at com.install4j.runtime.installer.controller.Controller.executeActions(Controller.java:355)
at com.install4j.runtime.installer.controller.Controller.handleCommand(Controller.java:212)
at com.install4j.runtime.installer.controller.Controller.start(Controller.java:111)
at com.install4j.runtime.installer.Installer.runInProcess(Installer.java:57)
at com.install4j.runtime.installer.Installer.main(Installer.java:45)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:85)
at com.exe4j.runtime.WinLauncher.main(WinLauncher.java:94)
at com.install4j.runtime.launcher.WinLauncher.main(WinLauncher.java:25)

We tried 3 different versions of the installer - 7.4.9, 7.6.3 and 7.12.2 - all with the same outcome.

We can't utilise the .zip file installation as we use Confluence as a Windows service, so we have to use the installer.

So, how do we get around this problem or shall we just ignore the error and proceed with the installation/upgrade regardless? Thanks.

1 answer

0 votes
Brant Schroeder Community Leader Oct 07, 2021

@George I would suggest upgrading confluence to use Java version 11 and seeing if that resolves the issue.  

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events