Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unexpected "Set up Confluence" startup page Edited

I needed to install a new certificate today, created the .JKS and edited the server.xml files to include the new store name and key password.  Done this several times in the past, never a problem.

Until today, luckily it's my development server.  After the cert install and service start my Confluence web site starts at the "Set up Confluence" page, like it thinks it's a brand new install.

I can't imagine what I could have done to make this happen.  I would sure appreciate  some ideas if anyone has any.

I have reverted to the old certificate thinking it might be a cert issue, as silly as that sounds.  No luck there, the setup screen happens on both certs.

2 answers

1 accepted

0 votes
Answer accepted

This happens when you reconnect Confluence to an empty database, or damage/remove the config file the database connection is stored.

Check that the file <confluence home>/confluence.cfg.xml contains the right connection settings for your Confluence database.

Thanks for the reply, I figured it out about the time you were responding.  I probably did it to myself somehow.

Solved.  Somehow the  confluence.cfg.xml which resides in the Confluence home directory got deleted, nothing to do with the cert, just fat fingers or something.

 

I assume the absence of the confluence.cfg.xml triggers the Set up Confluence initialization page.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.4.1
TAGS
Community showcase
Published in Confluence

🥓🙅🏻‍♀️ Meet-less May Badge!

Hello Confluence Community!  What if i told you that you could have a healthier life and be 100% meet-less? This month, we're promoting a healthy, balanced work diet with Confluence. (Read m...

617 views 4 26
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you