It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to update files in confluence.

Ok, hoping someone is able to help out with this. My group uses Confluence for just about everything so this is actually stopping me from doing almost any work. All of a sudden I try and update any file within our confluence page and the companion app launches my office doc, lets me edit. It recognizes me saving the document however it never advances beyond "saving" so I never get the update button. 

 

Tried clearing data, reinstall companion, reinstall office, multiple browsers, etc. Hopefully someone has an idea. This is an all of a sudden thing. Running O365 on Win 10.

 

Capture.PNG

2 answers

Did you check whether you are on the newest version of the Atlassian Companion? IIRC there was some security issue in early december so if you're still on an old version that might be the reason why it's not working.

EDIT: Just noticed that you said you tried a reinstall, so that's likely not the problem.

I did uninstall and reinstall the companion as part of my troubleshooting. However I followed a link on a search. If you have a verifiable link for the latest I could definitely try that out. It was early December when I last had a successful update. I was off work for two weeks in between then and now. 

I did verify I am on the latest version. Still unable to work with confluence.

Hi, I am having a client that is also experiencing this issue. Can you please confirm if:

  1. You use a proxy for your network
  2. Your network doesn't allow direct, unproxied access to api.media.atlassian.com
  3. It works fine if you edit files from outside your network, where you do have direct, unproxied access to Atlassian Cloud.
  4. If you look at the Companion logs, you can see an error like: 

Error: connect ETIMEDOUT <IP Address>:443
or 
Error: connect ECONNREFUSED <IP Address>:443

and that api.media.atlassian.com resolves to this IP address?

I am working with the theory that a regression error was introduced with 0.7.6 on 19 December, and the automatic update of the app (which is a good thing, because it was a serious security issue which caused this update) meant Companion mysteriously stopped working on many corporate networks. This issue still persists in Companion 1.0.0

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

109 views 3 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you