Unable to render user macro after migration to the 5.3.4 from 5.3.1

Hi

In 5.3.1, we used one usermacro and recently we migrated to 5.3.. But the earlier Usermarcro not rendereing(in fact showing raw text) properly.

Can you please help, how to resolve this problem. My User marco code is attached for yor reference.

Please help on this.

2 answers

Hello Uday,

try this instead of the wiki markup ({warning ...):

<ac:structured-macro ac:name="warning">
  <ac:parameter ac:name="title">This page is in draft mode.</ac:parameter>
  <ac:rich-text-body>
    <p>The content of this page has not yet been finalized.</p>
  </ac:rich-text-body>
</ac:structured-macro>

It's the same, but using the new storage format of Confluence. This should work.

Cheers,
Kirstin

Hi Kirstin,

Do you want me to replace the above code in User macro Text area section or Directly at Page edit section?

I would like to use this as a user macro in several pages. So please advice what to do?

Thanks in advance.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,031 views 15 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you