Unable to log in to Confluence, Jira works just fine

I am trying to clone an existing Confluence/Jira environment to do upgrade testing (this is Confluence 3.3 and Jira 4.2.4). The Confluence install uses the Jira DB for user authn/authz.

The cloned Jira environment is functional, and I can log in. The cloned Confluence environment is functional, but I cannot log in. It tells me "Sorry, your username and password are incorrect. Please try again." Multiple failures begin giving me a captcha I have to fill out. The config files are identical.

I've turned logging WAY up at /admin/viewlog4j.action, but nothing new is appearing in atlassian-confluence.log. I also turned on SQL logging, but not seeing anything in the log, or any new log files.

I am really at a loss.

4 answers

1 accepted

This widget could not be displayed.

I have been sync'ing just the data directories and databases.

After much fiddling and debugging with the help of JavaAtom on #atlassian, I did a fully rsync of the entire directories. That is, I rsync'ed the entire confluence and jira directories from production (/opt/local/_____) to the cloned server.

This worked, and auth worked on Confluence in the cloned environment. JavaAtom mentioned that maybe I didn't have the JNDI datasource in place in the cloned Confluence.

This widget could not be displayed.

Also: added com.atlassian.user and com.atlassian.confluence.user to the list of logging Classes, and set them to ALL.

This widget could not be displayed.

Delete the Trusted Application links (may need to remove the entires in the "trustedapp" table on both ends) and recreate them. Currenlty Confluence doesn't trust JIRA (or vice versa) because the authentication "fingerprints" have changed (much like a SSH or SSL fingerprint for a website or server).

How did you initially set up authentication?

I deleted the trusted apps, and configured new ones with the URLs of the cloned instances.

Still no worky. The Auth config on the Confluence config has a URL directly to the MySQL database. I don't know if actually does API calls for auth.

This widget could not be displayed.

Nothing new appearing in the log? Just want to double check this: have you changed the home directory location in the confluence-init.properties file in cloned installation folder?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

310 views 2 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you