Unable to instantiate VelocityEngine when running setup

I am trying to set up Confluence on a tomcat server on openshift, I followed the instructions here https://confluence.atlassian.com/display/CONF33/Installing+Confluence+EAR-WAR+on+Tomcat# but everytime I try to run the application it tells me that it cannot instantiate VelocityEngine.

2 answers

Looked at `velocity.properties` and changed it to this but still getting the same error for some reason.:

runtime.log.logsystem.class = com.atlassian.confluence.util.velocity.NullVelocityLogSystem

I have the same problem with:

  • Debian Squeeze 6.0.6
  • JDK 1.7.0-b147
  • MySQL 5.5.29
  • Tomcat 7.0.35

Jira 5.2.5 (war) seems to work OK.

With confluence 5.0 beta3 this doesn't happens... :/

I've tried with velocity.properties in the install dir of confluence and rebuilding the war but doesn't work. :(

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Monday in Confluence

Calling all marketing teams who use Confluence - we want to hear from you!

Hi Community! me again 🙂 If you’re a marketing team using Confluence, we want to hear your story! How did you start using Confluence? What are your use cases? What have been some of the benefits?...

200 views 3 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you