Unable to instantiate VelocityEngine when running setup

I am trying to set up Confluence on a tomcat server on openshift, I followed the instructions here https://confluence.atlassian.com/display/CONF33/Installing+Confluence+EAR-WAR+on+Tomcat# but everytime I try to run the application it tells me that it cannot instantiate VelocityEngine.

2 answers

This widget could not be displayed.

Looked at `velocity.properties` and changed it to this but still getting the same error for some reason.:

runtime.log.logsystem.class = com.atlassian.confluence.util.velocity.NullVelocityLogSystem

This widget could not be displayed.

I have the same problem with:

  • Debian Squeeze 6.0.6
  • JDK 1.7.0-b147
  • MySQL 5.5.29
  • Tomcat 7.0.35

Jira 5.2.5 (war) seems to work OK.

With confluence 5.0 beta3 this doesn't happens... :/

I've tried with velocity.properties in the install dir of confluence and rebuilding the war but doesn't work. :(

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Aug 14, 2018 in Confluence

Add-on evaluation with confluence templates

Atlassian market place contains number of Apps/Addons which improves the capability of out of the box Atlassian products. It is good to follow a plugin evaluation process before install add-ons. So t...

173 views 12 7
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you