Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,300,182
Community Members
 
Community Events
165
Community Groups

Unable to install Gliffy pluggin. Hangs at the install spin wheel window.

When trying to installing Gliffy gliffy-confluence-plugin-9.1.3.obr on our server 7.4.11 it  hangs at the spinning wheel window.  I've tried rebooting and restarting the services.  Same results.  I've tried other versions also. I have already contacted the vendor of gliffy and was unable to help. 

4 answers

Mine hung on update.  After 30 minutes, I restarted Confluence, disabled Gliffy, updated Gliffy successfully, re-enabled Gliffy.

I was also able to successfully install Gliffy after restarting Confluence.

Hi Bruce! So sorry for the delay — I'm hoping someone has been able to help you since this post.

You mention that you contacted the vendor — our support team's email is support@gliffy.com. Can you please confirm if that is who you reached out to?

Thank you!

Samie

Hi Samie

Yes, I have already worked with support@gliffy.com with Trish, and we came to a dead end. So she referred me to putting in a ticket with Atlassian.  Is this the right place to do that?

Thanks

Darn, I'm sorry Trish couldn't help!

This is the community center for Atlassian, so it's other Atlassian users trying to help you problem-solve. To file formal support ticket with Atlassian, you'll need to create a request here: https://support.atlassian.com/

Good luck!

0 votes
Kishan Sharma Community Leader Sep 13, 2021

Hi @Bruce Guy are you facing the similar issue on other browsers ? like mozilla firefox or edge ? I have had better luck with Mozilla in the past when I used to get such issues on Chrome.

Yes, same issues on different browsers, but I haven't tried edge.  I'll let you know how it goes.

0 votes
Charlie Misonne Community Leader Sep 10, 2021

Hi Bruce,

Couple of questions to troubleshoot this:

  1. Are you using manual the file upload method or the install button?
  2. Did you check your Confluence logs for any errors?
  3. Does it work for other plugins?

Hi Charlie

I am using the manual file upload method. 

The logs only show a timeout.  The server does not have access to the marketplace hence the last error.   But shouldn't affect the install I think. 

2021-09-10 12:53:06,746 WARN [https-jsse-nio-9445-exec-3] [confluence.util.profiling.DefaultActivityMonitor] close Exceeded the threshold of 60000 ms: ActivitySnapshot{startTime=1631296295460, threadId=220, threadName='https-jsse-nio-9445-exec-3', userId='bguy', type='web-request', summary='/'}
-- url: / | traceId: 9e8c5b7f72e90678 | userName: bguy | referer:

2021-09-10 12:54:05,589 WARN [https-jsse-nio-9445-exec-20] [atlassian.upm.pac.PacClientImpl] fetchMpacAppInfo Error when querying application info from MPAC: com.atlassian.marketplace.client.MpacException: org.apache.http.conn.ConnectTimeoutException: Connect to marketplace.atlassian.com:443 [marketplace.atlassian.com/104.192.142.7, marketplace.atlassian.com/104.192.142.6, marketplace.atlassian.com/104.192.142.8] failed: connect timed out

Other plugs ins work fine. 

 

I did find an error about gliffy in the log but not when I try to install. Not sure when this occurs. Probably when a page has a gliffy object to display.

2021-08-23 17:54:50,779 ERROR [ThreadPoolAsyncTaskExecutor::Thread 2] [internal.dependencies.startup.DependencyWaiterApplicationContextExecutor] fail Unable to create application context for [com.gliffy.plugin.confluence.gliffy-confluence-plugin], unsatisfied dependencies: none
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'diagramManager' defined in URL [bundle://297.0:0/META-INF/spring/atlassian-plugins-components.xml]: Bean instantiation via constructor failed; nested exception is org.springframework.beans.BeanInstantiationException: Failed to instantiate [com.gliffy.plugin.confluence.diagram.ConfluenceDiagramManager]: Constructor threw exception; nested exception is java.lang.NullPointerException
at org.springframework.beans.factory.support.ConstructorResolver.instantiate(ConstructorResolver.java:304)
at org.springframework.beans.factory.support.ConstructorResolver.autowireConstructor(ConstructorResolver.java:285)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.autowireConstructor(AbstractAutowireCapableBeanFactory.java:1340)

Did anyone ever find an resolution for this issue?  I am encountering the same thing.

No luck yet.  I'm still working on it .

I just upgraded Confluence to 7.13.4. I tried updating Gliffy Diagrams through the Manage Apps, and the installing just hangs...it's been like this for a day now. I can't do anything else in the Manage Apps because this is in the way.2022-02-13 22_18_12-Manage apps.png

Anyone found a solution?

We ran into this issue and found that restarting Confluence allowed us to install Gliffy.  

Like margagenova likes this

I have been experiencing the same issue for quite a while now. Usually I run through all of my software once every two weeks and update packages and the likes.
My original hypothesis was that Confluence needed restarting and this was often in conjunction with upgrading the version.


This time (Didn't want to upgrade Confluence) I tried
a) just installing - Hung at the "installing" part
b) Restarting Confluence - Hung at the "installing" part
c) Disabling app- Installed no hangs
d) Enabled app - Still ok

If it has hung there is no way to stop it, other than kill confluence. If you logout, close the browser window, etc then next time you log in and go to the manage apps it will pop up again.

 

Regards,

Steve B

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.4.11
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

352 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you