Unable to enable plugin pocketquery on Atlassian Confluence 4.3.7

2014-05-23 07:36:47,090 ERROR [main] [plugin.osgi.factory.OsgiPlugin] enableInternal Detected an error (BundleException) enabling the plugin 'de.scandio.confluence.plugins.pocketquery' : Unresolved constraint in bundle de.scandio.confluence.plugins.pocketquery [151]: Unable to resolve 151.0: missing requirement [151.0] package; (package=com.atlassian.confluence.plugins.index.api). This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D<br< a="">>2014-05-23 07:36:47,094 WARN [main] [plugin.osgi.factory.OsgiPlugin] enable Unable to enable plugin 'de.scandio.confluence.plugins.pocketquery'
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: de.scandio.confluence.plugins.pocketquery
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:445)
at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
at com.atlassia...


























































5 answers

This widget could not be displayed.

Hi Andrei,

We're facing some last problems making the plugin compatible with both Lucene versions in Confluence < 5.2 and >= 5.2. I'll check this in the next days and let you know when it's solved. Sorry for the inconvenience!

Regards, Felix

This widget could not be displayed.

Hi again, I uploaded a new version onto the marketplace. Please check it out and let me know if it works for you. If so, it would be nice if you could accept this answer ;). Thanks for collaborating!

Hi Felix, your customer got an error message like I get at the moment (although the context is different) and I wonder if you can help me. Do you have an idea how to solve https://answers.atlassian.com/questions/312201/missing-com.atlassian.confluence.plugins.index.api-on-atlas-integration-test-amps-5.0.3%2b-confluence-5.5? Thanks in advance! Kind regards Manuel

This widget could not be displayed.

Hi again, I uploaded a new version onto the marketplace. Please check it out and let me know if it works for you. If so, it would be nice if you could accept this answer ;). Thanks for collaborating!

This widget could not be displayed.

Hi Felix,

Updated Plugin and looks like it was enabled correctly.

Queries are working again.

This widget could not be displayed.

Very cool! Then I'd be glad if you accepted my answer :)

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

590 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you